[ovs-discuss] can not create device problem

Jesse Gross jesse at nicira.com
Mon Jun 21 21:48:16 UTC 2010

On Sat, Jun 19, 2010 at 6:27 PM, Yan <yan.p.bjtu at gmail.com> wrote:

> Hi Jesse
> Thank you for your reply and I'll take care to add cc. Sorry for last time.
> I saw the information from the *Create a GRE interface* thread, so I did
> like following:
> ovs-vsctl create interface name=gre0 type=gre options:remote_ip=remote
> machine's IP
> 99c94566-ea4f-41d9-9f40-d2e9c9a6d386
> ovs-vsctl create port name=gre0
> interfaces=[99c94566-ea4f-41d9-9f40-d2e9c9a6d386]
> f75aa483-e0ea-42e8-bb96-93110d630838
> ovs-vsctl add bridge dp0 ports f75aa483-e0ea-42e8-bb96-93110d630838
> And I also did the same thing at another machine.I got no error message but
> NOX didn't get a port event when I add gre into bridge(by ovs-vsctl add
> bridge dp0 ports f75aa483-e0ea-42e8-bb96-93110d630838).
>  I also tried ovs-vsctl add-port dp0 gre0 but it didn't inform nox either.
> It seems OVS doesn't send a event to NOX.
> In this case NOX will not tell the OVS to forward a flow via that tunnel
> even if the tunnel is correct.
> Would please offer some suggestions about how could this be solved?

OVS treats GRE ports just like normal Ethernet ports when it comes to
OpenFlow handling so if NOX isn't being notified it means that the port is
not being created correctly.  Your commands look correct, so can you post
the contents of your ovs-vswitchd log file?

Also, you're not using the userspace datapath are you?  GRE is only
implemented in the openvswitch_mod.ko kernel module.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://openvswitch.org/pipermail/ovs-discuss/attachments/20100621/f9c60290/attachment-0001.html>

More information about the discuss mailing list