[ovs-discuss] Fwd: OVS 0.90.7 build fails on kernel 2.6.31-14-generic

Prateek Jain prateek4tech at gmail.com
Tue Mar 23 21:05:56 UTC 2010

---------- Forwarded message ----------
From: Prateek Jain <prateek4tech at gmail.com>
Date: Tue, Mar 23, 2010 at 1:56 PM
Subject: Re: [ovs-discuss] OVS 0.90.7 build fails on kernel
To: Jesse Gross <jesse at nicira.com>


Thanks for your reply. I tried downloading and building 0.99.2 in the mean
I tried building for kernel modules, the build was successful, however the
of kernel module fails with the following error

insmod: error inserting './datapath/linux-2.6/openvswitch_mod.ko': -1
Invalid module format.

I ran 'configure' with the below options and the build succeeded

./configure --with-l26=/lib/modules/`uname -r`/build

What could be wrong ?

FYI: my linux host where i am trying to build and install openvswitch is
running on vmware.


On Tue, Mar 23, 2010 at 1:19 PM, Jesse Gross <jesse at nicira.com> wrote:

> On Tue, Mar 23, 2010 at 3:47 PM, Prateek Jain <prateek4tech at gmail.com>wrote:
>> Hello,
>> I am trying to build OVS 0.90.7 on Ubuntu 9.10 Linux kernel
>> 2.6.31-14-generic, the make fails with
>> below errors. Can you please tell me how to fix this ?
>  That release series is no longer being updated with support for newer
> kernels.  You'll either have to use the 0.99.2 release or checkout 'master'
> from git.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://openvswitch.org/pipermail/ovs-discuss/attachments/20100323/6be7b7df/attachment-0001.html>

More information about the discuss mailing list