[ovs-discuss] Fwd: OVS 0.90.7 build fails on kernel 2.6.31-14-generic

Prateek Jain prateek4tech at gmail.com
Tue Mar 23 23:27:38 UTC 2010


Hi,

Thanks, see the attached image, the vermagic output for an already loaded
module is same as the kernel module complied by me.

What else could be causing it ?

Thanks,
Prateek

On Tue, Mar 23, 2010 at 2:58 PM, Ben Pfaff <blp at nicira.com> wrote:

> On Tue, Mar 23, 2010 at 02:05:56PM -0700, Prateek Jain wrote:
> > Thanks for your reply. I tried downloading and building 0.99.2 in the
> > mean time.  I tried building for kernel modules, the build was
> > successful, however the loading of kernel module fails with the
> > following error
> >
> > insmod: error inserting './datapath/linux-2.6/openvswitch_mod.ko': -1
> > Invalid module format.
>
> Probably the compiler you used to build the module is different from the
> compiler used to build the kernel.  Compare the "vermagic" output by
> /sbin/modinfo for openvswitch_mod.ko against that output for a module
> installed in /lib/modules/`uname r`.
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://openvswitch.org/pipermail/ovs-discuss/attachments/20100323/169f9690/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: vermagic comparision.png
Type: image/png
Size: 86611 bytes
Desc: not available
URL: <http://openvswitch.org/pipermail/ovs-discuss/attachments/20100323/169f9690/attachment-0004.png>


More information about the discuss mailing list