[ovs-discuss] Installed open vswitch in XenServer 5.5

Jesse Gross jesse at nicira.com
Fri May 14 22:59:14 UTC 2010


On Fri, May 14, 2010 at 5:58 AM, Axle Judd <aix4200 at gmail.com> wrote:

>
>
> On Thu, May 13, 2010 at 10:51 PM, Jesse Gross <jesse at nicira.com> wrote:
>
>> Moving back on list.  Also, please do not top post.
>>
>> On Thu, May 13, 2010 at 4:08 AM, Axle Judd <aix4200 at gmail.com> wrote:
>>
>>> Jesse,
>>>
>>> shouldn't i need to delete the bridges -xenbr1-xenbr5 because i want to
>>> use NIC aggregation with br0 as a single bridge associated with NICS
>>> -eth1,eth2,eth3,eth4,eth5.
>>>
>>> What i want to accomplish use this single bridge with 6 aggregated NICS
>>> (each single NIC is VLAN trunked ) to use it for VM network.What i am
>>> guessing open vswitch will allow me to create VM's with different VLAN to
>>> pass the traffic using this bridge (br0).
>>>
>>> Isn't there something i need to customize in qemu-ifup scripts on
>>> XenServer 5.5. ?
>>>
>>
>> There's nothing that you need to customize in order to do either link
>> aggregation or VLANs.  Both of these operations can be setup using the
>> normal Xen tools (including XenCenter).  When you configure Xen it will
>> automatically set up Open vSwitch as appropriate to do the actual work.
>>
>
>
> Here is what i am running into I have 2 Quad port NIC's on XenServer 5.5
> with vswitch installed ( I build it using rpmbuild) then used rpm -ivh to
> install the compiled package.When i run brctl show i see :
>
> [root at xenserver5501 ~]# brctl show
> bridge name     bridge id               STP enabled     interfaces
> xenbr0          8000.0026b95c07c2       no              eth0
> xenbr1          8000.0026b95c07c4       no              eth1
> xenbr2          8000.0026b95c07c6       no              eth2
> xenbr3          8000.0026b95c07c8       no              eth3
> xenbr4          8000.002absac91aa       no              eth4
> xenbr5          8000.001b2154a6a9       no              eth5
> xenbr6          8000.0031b2154a6a       no              eth6
> xenbr7          8000.00312121bdba       no              eth7
>
> What i want to do is create a Network that i can use all NICS
> (eth0,eth1,eth2,eth3,eth4,eth5,eth6 and eth7) - all nics are connected to
> trunked VLAN.I don't see any documentation do i need to use Xen commands or
> ovs-vsctl commands to do this ?
>
> do i need to delete all these default bridge and create one using ovs-vsctl
> to use all ports eth0-eth7 ?
>
> Is there any documentation out there on open vswitch configuration on
> XenServer ?
>

Please send replies to the list as well.

Nothing you are trying to do is specific to Open vSwitch.  You need to use
Xen commands, instructions for which can be found in the XenServer
documentation.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://openvswitch.org/pipermail/ovs-discuss/attachments/20100514/3f39c592/attachment-0001.html>


More information about the discuss mailing list