[ovs-discuss] Question about open vswitch

신용진 akayong at gmail.com
Tue May 18 13:29:08 UTC 2010


Hello, I am trying to install open vswitch on my computer, however I have
some problems

 

My linux is CentOS5.3 and kernel version is 2.6.27.29, xen version is 3.4.2

 

Firstly, I downloaded the open vswitch via git. (git clone
git://openvswitch.org/openvswitch)

And I want to install open vswitch in kernel mode

So, I did configure with “--with-l26=/lib/modules/`uname -r`/build”
option.

 

After that, I loaded modules(openvswitch_mod.ko, brcompat_mod) with insmod

 

Then, 

 

I create db, and initiate it with “ovs-vsctl init”

Then, I started ovs-vswitchd.

 

To enable bridge functions,

I run

ovs-brcompatd --pidfile --detach -vANY:console:EMER
unix:/usr/local/var/run/openvswitch/db.sock

 

then, 

 

I did

 

vconfig add eth2 100

 

brctl addbr xenbr2

brctl addbr xenbr2.100

brctl addif xenbr2 eth2

brctl addif xenbr2.100 eth2.100

 

however, the log(?) of ovs-vswitchd shows like below

 

May 18 18:13:07|00001|reconnect|INFO|unix:/usr/local/var/run/openvswitch/db.
sock: connecting...

May 18 18:13:07|00002|reconnect|INFO|unix:/usr/local/var/run/openvswitch/db.
sock: connected

May 18 18:14:02|00003|ofproto|INFO|using datapath ID 0000002320db97ee

May 18 18:14:02|00004|bridge|INFO|created bridge xenbr2 on system at dp0

May 18 18:14:02|00005|bridge|INFO|created port xenbr2 on bridge xenbr2

May 18 18:14:02|00006|bridge|WARN|bridge xenbr2: using default bridge
Ethernet address 00:23:20:81:fc:d8

May 18 18:14:02|00007|xenserver|INFO|not running on a XenServer

May 18 18:14:02|00008|ofproto|INFO|datapath ID changed to 000000232081fcd8

May 18 18:14:02|00009|netdev_linux|WARN|xenbr2: removing policing failed:
Invalid argument

May 18 18:14:02|00010|bridge|WARN|bridge xenbr2: using default bridge
Ethernet address 00:23:20:81:fc:d8

May 18 18:14:02|00011|netdev_linux|WARN|xenbr2: removing policing failed:
Invalid argument

May 18 18:14:10|00012|bridge|INFO|created port eth2 on bridge xenbr2

May 18 18:14:10|00013|ofproto|INFO|datapath ID changed to 0000001517b83776

May 18 18:14:10|00014|netdev_linux|WARN|xenbr2: removing policing failed:
Invalid argument

May 18 18:14:10|00015|netdev_linux|WARN|eth2: removing policing failed:
Invalid argument

May 18 18:14:10|00016|netdev_linux|WARN|xenbr2: removing policing failed:
Invalid argument

May 18 18:14:10|00017|netdev_linux|WARN|eth2: removing policing failed:
Invalid argument

May 18 18:14:39|00018|ofproto|INFO|using datapath ID 0000002320ff65e8

May 18 18:14:39|00019|bridge|INFO|created bridge xenbr2.100 on system at dp1

May 18 18:14:39|00020|bridge|INFO|created port xenbr2.100 on bridge
xenbr2.100

May 18 18:14:39|00021|bridge|WARN|bridge xenbr2.100: using default bridge
Ethernet address 00:23:20:f3:f8:1a

May 18 18:14:39|00022|ofproto|INFO|datapath ID changed to 0000002320f3f81a

May 18 18:14:39|00023|netdev_linux|WARN|xenbr2: removing policing failed:
Invalid argument

May 18 18:14:39|00024|netdev_linux|WARN|eth2: removing policing failed:
Invalid argument

May 18 18:14:39|00025|netdev_linux|WARN|xenbr2.100: removing policing
failed: Invalid argument

May 18 18:14:39|00026|bridge|WARN|bridge xenbr2.100: using default bridge
Ethernet address 00:23:20:f3:f8:1a

May 18 18:14:39|00027|netdev_linux|WARN|xenbr2: removing policing failed:
Invalid argument

May 18 18:14:39|00028|netdev_linux|WARN|eth2: removing policing failed:
Invalid argument

May 18 18:14:39|00029|netdev_linux|WARN|xenbr2.100: removing policing
failed: Invalid argument

May 18 18:14:48|00030|bridge|INFO|created port eth2.100 on bridge xenbr2.100

May 18 18:14:48|00031|ofproto|INFO|datapath ID changed to 0000122d3e90469d

May 18 18:14:48|00032|netdev_linux|WARN|xenbr2: removing policing failed:
Invalid argument

May 18 18:14:48|00033|netdev_linux|WARN|eth2: removing policing failed:
Invalid argument

May 18 18:14:48|00034|netdev_linux|WARN|xenbr2.100: removing policing
failed: Invalid argument

May 18 18:14:48|00035|netdev_linux|WARN|eth2.100: removing policing failed:
Invalid argument

May 18 18:14:48|00036|netdev_linux|WARN|xenbr2: removing policing failed:
Invalid argument

May 18 18:14:48|00037|netdev_linux|WARN|eth2: removing policing failed:
Invalid argument

May 18 18:14:48|00038|netdev_linux|WARN|xenbr2.100: removing policing
failed: Invalid argument

May 18 18:14:48|00039|netdev_linux|WARN|eth2.100: removing policing failed:
Invalid argument

 

I found that messages in ../lib/netdev-linux.c however, I could not fix
those messages.

 

 

Anyway, I set ip to xenbr2 and xenbr2.100.

 

If I do “ping” from other server to xenbr2 or xenbr2.100 it works, 

However, if I do “ping” from the server(that openvswitch is installed)
through xenbr2 or xenbr2.100 it didn’t works.

I cannot do any networking through xenbr2 or xenbr2.100

 

How does it works? Is there any examples which has successful setup with
openvswitch?

I searched on google, however, I could not found it.

 

I downloaded 1.0.0 (the latest version) today, and do same thing, however,
it was same.

 

If you need more information about this problem, please let me know.

 

 

Thanks in advance.

 

 

-       Steve

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://openvswitch.org/pipermail/ovs-discuss/attachments/20100518/b07a853f/attachment-0001.html>


More information about the discuss mailing list