[ovs-discuss] Problem with OpenVswitch 1.0.0 database backend and persistent settings.

Mark Persohn Mark.Persohn at superchoice.com.au
Thu May 20 08:47:24 UTC 2010


Hi,

We are currently using v0.90.7 with the text based conf file.  We have a host running 2 virtual machines on different networks, 
hence the use of openvswitch.
Vlan 4 is connected to the host itself with an internal vswitch port.
Vlan 5 and 6 are for the 2 Virtual Machines.
The Virtual Machines are managed by libvirtd and are based KVM and qemu.
Currently when we start the VM's they bridge themselves to the brovs1 interface.  Below you will see the config file before the VM starts.

  bridge.brovs1.port=bond1
  bridge.brovs1.port=brovs1
  bridge.brovs1.port=intovs0
  iface.intovs0.internal=true
  vlan.brovs1.trunk=4
  vlan.brovs1.trunk=5
  vlan.brovs1.trunk=6
  vlan.intovs0.tag=4
  vlan.netwin0.tag=6
  vlan.vnet0.tag=5

And after
  bridge.brovs1.port=bond1
  bridge.brovs1.port=brovs1
  bridge.brovs1.port=intovs0
  bridge.brovs1.port=netwin0
  iface.intovs0.internal=true
  vlan.brovs1.trunk=4
  vlan.brovs1.trunk=5
  vlan.brovs1.trunk=6
  vlan.intovs0.tag=4
  vlan.netwin0.tag=6
  vlan.vnet0.tag=5
As you can see the brcompat process has added the netwin0 interface and the conf file has allowed vlan 6 traffic
 to flow as it was defined in the config prior to starting.  The VM has network connectivity.
 
Under v1.0.0 I can find no way to define the vlan port access prior to the port existing in the database.
What happens now is the port does not exist until the VM starts.  This means that the tag=6 option needed 
to get traffic flowing from the VM to the network does not happen until I run:
  'ovs-vsctl set port netwin0 tag=6'
Is there a way of defining this prior to the port being created on VM startup like it was with the conf file?

I have looked at trying to run a script as prt of the VM startup but since we are running libvirtd/qemu in bridge 
mode it will not run scripts!  The old conf file mode made running VM's with libvirtd/qemu very easy/elegant.  
Do I have any options to get this working with 1.0.0?

Thanks in advance.

Mark
  

 
 
 




Please consider the environment before you print this email
For email conditions, please see our website  http://www.superchoice.com.au/email_conditions.htm




More information about the discuss mailing list