[ovs-discuss] An error : flow.h:36: error: field ‘used’ has incomplete type

Ben Pfaff blp at nicira.com
Thu May 27 16:25:02 UTC 2010


On Thu, May 27, 2010 at 10:26:21PM +0900, 蒲彦 wrote:
> Hello dear all, today I got a snapshot from git but when I try to compile it
>   CC [M]  /home/yan/openvswitch/datapath/linux-2.6/flow.o
> In file included from /home/yan/openvswitch/datapath/linux-2.6/flow.c:9:
> /home/yan/openvswitch/datapath/linux-2.6/../flow.h:36: error: field ‘used’
> has incomplete type

Yes, there was a missing #include in this file that showed up on 2.6.26.
If you pull from the repository, I have already fixed it.




More information about the discuss mailing list