[ovs-discuss] [Bug] flow deletion before transmission end - transmission stalled

Christian Fischer christian.fischer at easterngraphics.com
Fri Nov 26 14:52:19 UTC 2010


Is there a known bug with 1.1.0pre2 on XCP-0.5 which prevents from e.g. 
copying files bigger than 1.3kb via scp over vlan trunks?

Tried to copy over physical eth0, transmission stalles, trunks=501.
Tried to copy over physical eth0, transmission ok, tag=501.

No problem with arp requests/replies after sending/receiving a lot of acks.

Reproducable: always, stalles after asking for password and printing
 "100% ...0:00"

Fish reports "No route to host", ssh works, ping works, Xen manager https 
works.

Tcpdump can't see any packets on eth0 after connection is stalled but the 
pysical switch connected to eth0 is sending them (tcpdump listening on mirror 
port, lot of acks and arp).

As far I could see ovs deletes the flows before the transmission ends. No new 
calls of process_flow() after deletion for this connection, only for new ones. 

Comments?

Regards
Christian




More information about the discuss mailing list