[ovs-discuss] openvswitch (Ubuntu) bug

Ben Pfaff blp at nicira.com
Mon Nov 29 18:46:59 UTC 2010


On Thu, Nov 25, 2010 at 01:25:22AM +0000, Dave Walker wrote:
> On 24/11/10 20:25, Ben Pfaff wrote:
> >It looks like Open vSwitch just needs to use pkg-config to check for
> >openssl instead of libssl.
> >
> >Here's a patch, does it fix it?
>
> Ooo, well caught.  I can confirm this fixes the issue on both Ubuntu
> Natty (11.04), and the current Debian Sid package (1.1.0~pre2-5)
> does still build.  

Thank you.  I pushed this fix to our "master" branch.

> I also wanted to add that the recent s/any/linux-any/ change [0] is
> currently incompatible with Ubuntu build process due to a bug our
> side [:(], which causes no binary packages to be built; therefore I
> reverted this change [1] in our package.  Short term, I think this
> needs to be a maintained delta between Ubuntu and Debian - until the
> bug with the build system is resolved.

Seems reasonable.  Let me know if you think a change is warranted on our
end.

> I also wanted to raise that we are currently working on adding an
> additional binary package, which includes dkms support for the
> kernel module.  Would it be possible to submit this for inclusion in
> your upstream packaging, once it is tested?

I think I answered this already, but, yes, this sounds good to me.

Thanks,

Ben.




More information about the discuss mailing list