[ovs-discuss] Help Connecting Switch to VMs

Justin Pettit jpettit at nicira.com
Tue Oct 5 06:46:04 UTC 2010


I assume that you're running VirtualBox on a Linux host, correct?  If so, have you gotten networking to work out of the box (i.e., no Open vSwitch)?  If not, then I'd recommend doing that first, since that will be documented on the VirtualBox site and support forums.  If you get all that working, you could then try running Open vSwitch with bridge compatibility:

	http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=blob_plain;f=INSTALL.bridge;hb=HEAD

If all that works, then we can discuss how to switch over to natively using the Open vSwitch commands, which should be pretty trivial.  In the meantime, why don't you let us know where you run into troubles?

--Justin


On Oct 4, 2010, at 10:57 PM, Derek Cormier wrote:

> Hello,
> 
> I am trying to set up an Open vSwitch configuration where OVS is installed on a virtual machine and other virtual machines connect to it. I am using Virtual Box. Because I have only begun to study networking, this is naturally difficult for me. After reading the documentation, I still cannot figure out how to connect a port from the virtual switch to a port on another virtual machine. The switch vm has a host-only network to my machine and the other vm's are connected to the switch via an internal network (http://www.virtualbox.org/manual/ch06.html has a description of these network types).
> 
> I would appreciate if anyone could give me some advice without, if possible, the assumption I know a lot about networking.
> 
> Thank you,
> Derek
> 
> _______________________________________________
> discuss mailing list
> discuss at openvswitch.org
> http://openvswitch.org/mailman/listinfo/discuss_openvswitch.org





More information about the discuss mailing list