[ovs-discuss] Help Connecting Switch to VMs

Justin Pettit jpettit at nicira.com
Thu Oct 7 09:04:37 UTC 2010

On Oct 7, 2010, at 1:44 AM, Derek Cormier wrote:

> Okay, I now have a better understanding of the project I am working on. I'll be using the OpenFlow functionality, not the Linux bridging replacement. This that leads me to another problem. I was following the instructions for setting up an OpenFlow switch (http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=blob_plain;f=INSTALL.OpenFlow;hb=HEAD), and on step where I run ovs-openflowd, I get a segmentation fault. Here is my console output:
> $ sudo ovs-openflowd dp0
> Oct 07 17:37:56|00001|openflowd|INFO|Open vSwitch version 1.1.0pre2
> Oct 07 17:37:56|00002|openflowd|INFO|OpenFlow protocol version 0x01
> Oct 07 17:37:56|00003|ofproto|INFO|using datapath ID 000000232080e6c1
> Segmentation fault
> I created dp0 and added ethernet ports to it. ovsdb-server is running and openvswitch_mod is loaded.

I was able to reproduce this problem.  It sounds like you may have worked around the issue, but I'll try to get a fix out in the next day or two.

Thanks for bringing this to our attention!


More information about the discuss mailing list