[ovs-discuss] Getting OpenFlow Set Up

Derek Cormier derek.cormier at lab.ntt.co.jp
Thu Oct 14 02:46:20 UTC 2010


Hmm it seems I was wrong. I was able to get ovs-openflowd running just 
using a datapath with no virtual bridge involved. I thought this was 
necessary... When is it necessary, when you are using ovs-vswithd?

On 10/14/2010 10:02 AM, Derek Cormier wrote:
> Hello,
>
> After much hard work, troubleshooting, and experimenting, I was 
> finally able to get OpenFlow up and running! However, I am now trying 
> to make the steps concrete and I have a few questions.
>
> I created my virtual bridge vbr0 using ovs-vsctl while ovs-vswitchd 
> was running. I now want to use ovs-openflowd instead. However, it 
> seems I cannot form a connection between ovs-controller and 
> ovs-openflowd unless I do an ifconfig on vbr0. This, however, requires 
> ovs-vswitchd to be running. How can I do this using only ovs-openflowd?
>
> Also, I'm not exactly sure which IP address I should use for the 
> datapath, and which IP address I should use for running in-band 
> communication. I tried using ptcp: to connect the controller and 
> OpenFlow switch but this didn't work.
>
> My set-up is as follows:
>
> - Open vSwitch runs in a Virtual Machine.
> - Other vm hosts connect to the switch vm via an internal network (one 
> for each host).
>
> _______________________________________________
> discuss mailing list
> discuss at openvswitch.org
> http://openvswitch.org/mailman/listinfo/discuss_openvswitch.org
>
>
>





More information about the discuss mailing list