[ovs-discuss] Getting OpenFlow Set Up

Derek Cormier derek.cormier at lab.ntt.co.jp
Mon Oct 18 08:07:23 UTC 2010


On 10/18/2010 01:22 PM, Derek Cormier wrote:
> On 10/18/2010 01:00 PM, Derek Cormier wrote:
>> On 10/18/2010 11:11 AM, Jesse Gross wrote:
>>> On Sun, Oct 17, 2010 at 6:21 PM, Derek Cormier
>>> <derek.cormier at lab.ntt.co.jp>  wrote:
>>>> On 10/18/2010 09:36 AM, Justin Pettit wrote:
>>>>> On Oct 17, 2010, at 5:28 PM, Derek Cormier wrote:
>>>>>
>>>>>
>>>>>> When you add ports to a virtual bridge, should you still be able 
>>>>>> to ping
>>>>>> them? For some reason, I cannot ping the interface on the switch 
>>>>>> that a host
>>>>>> connects to. Yet, I can ping another host.
>>>>>>
>>>>> Do you mean, for example, if you add eth0 to br0, you can't ping the
>>>>> address assigned to eth0?  If so, then, no, you cannot ping the 
>>>>> addresses of
>>>>> attached devices.  You can assign the IP address to br0, though, 
>>>>> and that
>>>>> should work.
>>>>>
>>>>> --Justin
>>>>>
>>>>>
>>>> Yep, that's exactly what I meant. I tried giving my bridge, vbr0 an IP
>>>> address using:
>>>>
>>>>   ifconfig vbr0 192.168.100.1,
>>>>
>>>> But I am unable to ping it. In order to get ping working before, 
>>>> when I was
>>>> pinging from host to host, I had to set up the default entry on 
>>>> each host to
>>>> be their outgoing interface, because it wouldn't work with the routers
>>>> incoming interface. Should the default entry for the hosts be 
>>>> vbr0's new IP
>>>> address?
>>> Yes, all configuration should use the bridge interface's IP/MAC
>>> address.  The underlying Ethernet adapters become owned by the switch
>>> and it will take all traffic before it hits the IP stack.
>>>
>>>
>>>
>>>
>>
>> Aah I see, thanks for making that clear. However, even after setting 
>> the hosts' routing tables to point to vbr0's IP address, I am still 
>> unable to ping it.
>>
>> -Derek
>>
>> _______________________________________________
>> discuss mailing list
>> discuss at openvswitch.org
>> http://openvswitch.org/mailman/listinfo/discuss_openvswitch.org
>>
>>
>>
>
> It works now! I had the hosts on a different subnet than Open 
> vSwitch's subnet...
>
> -Derek
>
>
> _______________________________________________
> discuss mailing list
> discuss at openvswitch.org
> http://openvswitch.org/mailman/listinfo/discuss_openvswitch.org


Now I can ping each host from each other host, and ping the switch as 
well. However, I cannot seem to ping the hosts from switch as well.

I am using ovs-ofctl ping <host-addr>. Any ideas why?

Thanks,
-Derek





More information about the discuss mailing list