[ovs-discuss] [Open vSwitch 1.1.0-pre1] ovs-vsctl hangs with ovs-vsctl set-controller <bridge> tcp:<ip>

Vishal Swarankar vishal.swarnkar at gmail.com
Wed Sep 8 04:05:34 UTC 2010


My SUT crashed yesterday. Once it comes up, I will follow the same steps
again and post the logs here.

thanks
Vishal

On Wed, Sep 8, 2010 at 9:25 AM, Ben Pfaff <blp at nicira.com> wrote:

> On Tue, Sep 7, 2010 at 8:37 PM, Vishal Swarankar
> <vishal.swarnkar at gmail.com> wrote:
> > I have tried this multiple time with Open vSwitch 1.1.0-pre1 (Sep 01/10
> > release).
> >
> > Steps to repro:
> >
> > 1) follow INSTALL.LINUX steps to install vswitch ( ovsdb-server,
> > ovs-vswitchd is running and bridge is installed using ovs-vsctl ).
> >
> > 2) Run ovs-controller on the same machine
> >     sudo ovs-controller -v --with-flows /home/vishal/newVMs/flow-rules
> > --log-file controller.log ptcp:
> >
> > 3) Run ovs-vsctl to setup Of controller for vswitch
> >     sudo ovs-vsctl set-controller <bridge> tcp:<ip>
> >
> > This command never returns back and when I do ps -eaf | grep vswitchd, I
> > dont find vswitchd running.
>
> Did ovs-vswitchd die?  Can you turn on core dumps and pass along a
> backtrace?
> Can you pass along what ovs-vswitchd, ovsdb-server, and ovs-vsctl wrote to
> the system log?
>
> Thanks,
>
> Ben.
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://openvswitch.org/pipermail/ovs-discuss/attachments/20100908/5be90ce2/attachment-0001.html>


More information about the discuss mailing list