[ovs-discuss] [Open vSwitch 1.1.0-pre1] ovs-vsctl hangs with ovs-vsctl set-controller <bridge> tcp:<ip>

Ben Pfaff blp at nicira.com
Wed Sep 8 05:00:36 UTC 2010


OK, that's a known bug in that case.  It was fixed soon after the release of
1.1.0-pre1.  If you get the latest from Git "master", it will have that fix,
and this will also be fixed in 1.1.0-pre2.

On Tue, Sep 7, 2010 at 9:50 PM, Vishal Swarankar
<vishal.swarnkar at gmail.com> wrote:
> I can find an assert assert(size <= ofpbuf_headroom(b)) in ofpbuf.c in
> vswitcd logs. I will come up with more info.
>
> thnx
>
> On Wed, Sep 8, 2010 at 9:35 AM, Vishal Swarankar <vishal.swarnkar at gmail.com>
> wrote:
>>
>> My SUT crashed yesterday. Once it comes up, I will follow the same steps
>> again and post the logs here.
>>
>> thanks
>> Vishal
>>
>> On Wed, Sep 8, 2010 at 9:25 AM, Ben Pfaff <blp at nicira.com> wrote:
>>>
>>> On Tue, Sep 7, 2010 at 8:37 PM, Vishal Swarankar
>>> <vishal.swarnkar at gmail.com> wrote:
>>> > I have tried this multiple time with Open vSwitch 1.1.0-pre1 (Sep 01/10
>>> > release).
>>> >
>>> > Steps to repro:
>>> >
>>> > 1) follow INSTALL.LINUX steps to install vswitch ( ovsdb-server,
>>> > ovs-vswitchd is running and bridge is installed using ovs-vsctl ).
>>> >
>>> > 2) Run ovs-controller on the same machine
>>> >     sudo ovs-controller -v --with-flows /home/vishal/newVMs/flow-rules
>>> > --log-file controller.log ptcp:
>>> >
>>> > 3) Run ovs-vsctl to setup Of controller for vswitch
>>> >     sudo ovs-vsctl set-controller <bridge> tcp:<ip>
>>> >
>>> > This command never returns back and when I do ps -eaf | grep vswitchd,
>>> > I
>>> > dont find vswitchd running.
>>>
>>> Did ovs-vswitchd die?  Can you turn on core dumps and pass along a
>>> backtrace?
>>> Can you pass along what ovs-vswitchd, ovsdb-server, and ovs-vsctl wrote
>>> to
>>> the system log?
>>>
>>> Thanks,
>>>
>>> Ben.
>>
>
>




More information about the discuss mailing list