[ovs-discuss] vLANS is not working on Gentoo x86_64

benzwt benzwt benzwt at gmail.com
Wed Apr 6 10:40:30 UTC 2011

hi openvswitch users,

I have two servers, one running linux kernel 2.6.38(gentoo) and the
other running ubuntu (10.10)
I tried to setup a vLANs environment using latest snaphot

I followed the steps written in Install.Linux, and everything was good
on the both servers.
Then, I created two KVM separately, ordering to the document Install.KVM.
After that, I created a VLANs environment according to the cookbook,

However, The two KVMs (one on gentoo, the other on ubuntu) couldn't
communicate with each other(using ping), provided that the "tag" was
Moreover, the communication was good after removing the tag.

I then installed other ubuntu(10.10) server and setup the VLANs
environment with the ubuntu server(10.10) I have mentioned earlier.
Finally, the vLANs worked perfectly on this configuration.(one VM on
ubuntu0, and the other on ubuntu1)

It seemed that the problem was on the gentoo server.
Thus, I created two KVMs on the gentoo server and setup the vLANs
environment.(both of the VMs was running on the same host).
This time, the vLANs was good.

In short, the vLANs is working only if the VMs are running on the same
gentoo host.

I doubt that my gentoo kernel is lacking some modules that are
important to openvswitch.

Please give me some advices.


More information about the discuss mailing list