[ovs-discuss] Fwd: Problems with WinXP vms

Tom Brown nextstate at gmail.com
Mon Apr 11 20:39:01 UTC 2011


---------- Forwarded message ----------
From: Tom Brown <nextstate at gmail.com>
Date: Mon, Apr 11, 2011 at 13:30
Subject: Re: [ovs-discuss] Problems with WinXP vms
To: Ben Pfaff <blp at nicira.com>


On Fri, Apr 8, 2011 at 15:43, Ben Pfaff <blp at nicira.com> wrote:

> On Fri, Apr 08, 2011 at 03:36:34PM -0700, Tom Brown wrote:
> > I have been running into problems with running XP in a vm (using
> qemu-kvm)
> > attached to a vswitch.
> ...
> > Any ideas or suggestions would be appreciated.
>
> What version of OVS are you using?
>
> What's in the OVS log?
>
> Thanks,
>
> Ben.
>

The version of ovs I'm using is: v1.1.0pre2 - 13 Sep 2010

There wasn't any log, so I turned on verbose logging. A log snippet can be
found here: http://hpaste.org/45582/ovs_log
The snippet includes the time frame that I ran our application.

I believe I solved the issue with not being able to access some of the vms.
I removed an erroneous default route and all the vms were accessible.

There is something to note about our application. We create additional
mac/ip pairs on the XP vms. If we create one mac/ip pair on the XP vm, the
application succeeds without errors. If we create two or more mac/ip pairs,
we get the errno 87 every time we perform a "load" from the client to the
server. The initial connection always works, but the "load" is when the
mac/ip pairs are generated. Additionally, the ip is provided through DHCP.
However, when the ip is allocated statically, the "load" works without
error.

If I create additional interfaces in Linux, there doesn't seem to be a
problem. Although, we can't test it with our application, which is Windows
only.

Thanks!
Tom
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://openvswitch.org/pipermail/ovs-discuss/attachments/20110411/494dabf8/attachment.html>


More information about the discuss mailing list