[ovs-discuss] vLANS is not working on Gentoo x86_64

Jesse Gross jesse at nicira.com
Thu Apr 14 17:49:27 UTC 2011


On Mon, Apr 11, 2011 at 11:30 AM, Jesse Gross <jesse at nicira.com> wrote:
> On Sat, Apr 9, 2011 at 6:38 AM, benzwt benzwt <benzwt at gmail.com> wrote:
>> First of all, thank you for your helpful information.
>>
>> I'm sorry, I just realized that the e1000e drivers for linux-2.6.35
>> and linux-2.6.38 is different, by "diff"ing the codes.
>> I then suspected that maybe ubuntu(2.6.35) had patched the 8021q.
>> After checking the codes, it turn out that the 8021q wasn't patched.
>>
>> I'll try to build e1000e module from linux-2.6.35 and test the VLANs.
>
> There's too many moving parts here to just take pieces independently.
> The vlan core infrastructure changed, which means that both Open
> vSwitch and the drivers behave differently on the various kernel
> versions.
>
> If possible, the easiest solution is to just run on 2.6.35 for the time being.

Actually, one of the Intel guys just posted a patch for the e1000e
driver that is likely to resolve the problem:
http://patchwork.ozlabs.org/patch/91147/



More information about the discuss mailing list