[ovs-discuss] open vswitch configuration

Justin Pettit jpettit at nicira.com
Sat Apr 30 06:19:05 UTC 2011


Why do you think Bridge0 should not be able to ping Bridge1?  It looks to me like they're all connected at the wireless router.  In your original message, you mentioned VLANs, but I don't see them in the description you just gave.

--Justin


On Apr 29, 2011, at 10:36 PM, ahmad numan wrote:

> <myimage.JPG>
> 
> Above is the topology of my network. I configured the Laptop A with Bridge0 and add two physical interfaces to it. On Laptop B it added two interfaces to separate bridges. Interface at Bridge1 should not ping the interfaces at Bridge0 but it is pinging. My configuration is as follows
> Configuration
> -------------------
> After installing the open vswitch
> 
>  ovsdb-tool create /usr/local/etc/ovs-vswitchd.conf.db vswitchd/vswitch.ovsschema
> 
>  ovsdb-server /usr/local/etc/ovs-vswitchd.conf.db  --remote=punix:/usr/local/var/run/openvswitch/db.sock --remote=db:Open_vSwitch,managers --private-key=db:SSL,private_key --certificate=db:SSL,certificate --bootstrap-ca-cert=db:SSL,ca_cert --detach
> 
>  ovs-vsctl --no-wait init
> 
>  ovs-vswitchd unix:/usr/local/var/run/openvswitch/db.sock --detach
> 
> ovs-vsctl add-br bridge0
> 
> ovs-vsctl add-port bridge0 eth1
> 
> similarly i added bridges and ports to bridges.
> 
> Note
> ------
> I don't use virtual machines
>  
> I think there is something missing in configuration. Please help me
> thanks
> 
> Ahmed Bilal
> 
> 
> 
> On Sat Ar 32011 at 3:39 AM, Ben Pfaff <blp at nicira.com> wrote:
> On Sat, Apr 30, 2011 at 12:55:32AM +0500, ahmad numan wrote:
> > I am experimenting with OVS but having unexpected results. I interconnect
> > two Laptops having *eth0* and *wlan0* interfaces using a wireless router.
> > Each interfacing is pinging the other. Now i configured the OVS according to
> > "INSTALL.Linux" and tutorial for setting VLAN in OVS documentation. On one
> > laptop i *added two interfaces to bridge0* and other laptop *one interface
> > is added to bridge0 and other interface is added to bridge1*. The interface
> > added to bridge1 should not ping the interfaces of other laptop interfaced
> > that are added to bridge0. But they are pinging. please help me out where i
> > am wrong.
> 
> I don't understand this description.  I could guess about what it
> really is, but maybe you could show us a little more explicitly?  For
> example, you could draw an ASCII art diagram or you could describe the
> path of a packet from one end to another.
> 
> _______________________________________________
> discuss mailing list
> discuss at openvswitch.org
> http://openvswitch.org/mailman/listinfo/discuss




More information about the discuss mailing list