[ovs-discuss] Bridge Compatible Mode: /sys/class/net/br0/bridge: No such file or directory

Shi Jin jinzishuai at gmail.com
Fri Jul 8 05:59:20 UTC 2011


Hi,
I am using open vswitch version 1.1.1 and sysfs is mounted.
Thanks.

Shi

On Thu, Jul 7, 2011 at 2:23 PM, Ben Pfaff <blp at nicira.com> wrote:

> On Wed, Jul 06, 2011 at 05:32:06PM -0600, Shi Jin wrote:
> > I am trying to get open vswitch to work with libvirt/KVM on RHEL as part
> of
> > integration into OpenNebula.
> > I loaded Linux bridge compatible module and use "brctl adbr" to create
> > bridge devices.
> >
> > However, I got some errors in "brctl show"
> >
> > [root at node5 openvswitch]# brctl show
> > bridge name    bridge id        STP enabled    interfaces
> > br0        /sys/class/net/br0/bridge: No such file or directory
> > /sys/class/net/br0/bridge: No such file or directory
> > /sys/class/net/br0/bridge: No such file or directory
> > /sys/class/net/br0/bridge: No such file or directory
> > /sys/class/net/br0/bridge: No such file or directory
> > /sys/class/net/br0/bridge: No such file or directory
> > /sys/class/net/br0/bridge: No such file or directory
> > /sys/class/net/br0/bridge: No such file or directory
> > /sys/class/net/br0/bridge: No such file or directory
> > /sys/class/net/br0/bridge: No such file or directory
> > /sys/class/net/br0/bridge: No such file or directory
> > /sys/class/net/br0/bridge: No such file or directory
> > 0000.0024e8561195    no        eth1
>
> I don't see those errors here with OVS and ovs-brcompatd from the
> current "master" branch.  What version of OVS are you using?
>
> Is /sys mounted?
>



-- 
Shi Jin, Ph.D.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://openvswitch.org/pipermail/ovs-discuss/attachments/20110707/92ae2ec3/attachment.html>


More information about the discuss mailing list