[ovs-discuss] Fwd: nova/openvswitch

Justin Pettit jpettit at nicira.com
Sun Jun 5 08:19:01 UTC 2011


[Once again, let's keep this on the mailing list.]

Are you running OVS in bridge compatibility mode?  (Specifically, is the brcompat_mod kernel module loaded?)   If it is, I imagine that things could get very confused about which networking "bridge" should be receiving commands.

Generally, if you're running OVS, you shouldn't need to be running the bridge.

--Justin


On Jun 5, 2011, at 1:05 AM, manel med wrote:

> I patch the kernel to allow both to run at the same time, I use 2.6.36.
> 
>  lsmod | grep bridge
>  bridge    70361  0
> stp            1603   2 grap,bridge
> 
> manel
>  
> 
> 2011/6/5 Justin Pettit <jpettit at nicira.com>
> [Let's keep this on the list.]
> 
> On Jun 4, 2011, at 4:31 PM, manel med wrote:
> 
> > I know that it's appear in "brctl show"and in "ovs-vsctl list bridge" and not in "ovs-vsctl list bridge" but i don't know why.
> > i run
> > insmod datapath/linux-2.6/openvswitch_mod.ko (how may time should i run it?)
> 
> You should run it only once.  My question was whether the bridge module was installed, too:
> 
>        lsmod | grep bridge
> 
> OVS will normally complain about this, but some later versions of the kernel allow both to run at the same time, and I'm not sure how OVS handles that situation.
> 
> > i use openvswitch-1.1.0.
> 
> I don't know that it will fix your particular problem, but 1.1.1 is out.  Please try that.
> 
> --Justin
> 
> 
> 




More information about the discuss mailing list