[ovs-discuss] openvswitch_mod: disagrees about version of symbol module_layout

Daniel Philip dany1212 at gmail.com
Thu May 26 16:07:41 UTC 2011


Sorry Ben, I don't get you.

when I type, $/sbin/modinfo, I don't see anything.  I followed the same
exact steps:

$ wget http://openvswitch.org/releases/openvswitch-1.1.0pre2.tar.gz
 $ tar zxvf openvswitch-1.1.0pre2.tar.gz
 $ cd  openvswitch-1.1.0pre2

Step2. Compile


 $ ./boot.sh
 $ ./configure --with-l26=/lib/modules/`uname -r`
 $ make

Step3. Run OpenFlow switchInsert OpenFlow kernel module, openvswitch_mod.ko.


 $ su -
 # /sbin/insmod ./datapath/linux-2.6/openvswitch_mod.ko



On Thu, May 26, 2011 at 6:01 PM, Ben Pfaff <blp at nicira.com> wrote:

> It's the same file you passed to insmod.
>
> On Thu, May 26, 2011 at 06:00:08PM +0200, Daniel Philip wrote:
> > Hi Ben,
> >
> > Thanks for replying. I tried % /sbin/modinfo /lib/modules/`uname
> > -r`/kernel/net/bridge/bridge.ko and obtained the following
> >
> > openflow at openflow:~/openvswitch-1.1.0pre2$ /sbin/modinfo
> > /lib/modules/2.6.32-28-generic/kernel/net/bridge/bridge.ko
> > filename:
> /lib/modules/2.6.32-28-generic/kernel/net/bridge/bridge.ko
> > version:        2.3
> > license:        GPL
> > srcversion:     7F81763D8FF0740B7DEF245
> > depends:        stp
> > vermagic:       2.6.32-28-generic SMP mod_unload modversions 586
> >
> >
> > But, I could not find openvswitch_mod.ko under /sbin/modinfo.
> >
> > Could you please assist ?
> >
> > Thanks,
> > Daniel
> >
> >
> >
> > On Thu, May 26, 2011 at 5:55 PM, Ben Pfaff <blp at nicira.com> wrote:
> >
> > > On Thu, May 26, 2011 at 05:46:15PM +0200, Daniel Philip wrote:
> > > > I get the following message when I try to run openvswitch using
> > > "/sbin/insmod
> > > > ./datapath/linux-2.6/openvswitch_mod.ko"
> > > >
> > > > insmod: error inserting './datapath/linux-2.6/openvswitch_mod.ko': -1
> > > > Operation not permitted
> > > >
> > > > Hence, I tried dmesg | test and it shows the following message:
> > > >
> > > > openvswitch_mod: disagrees about version of symbol module_layout
> > > >
> > > > Could anyone please let me know what should I be doing to avoid this?
> > >
> > > I imagine that you built against some kernel version other than the
> > > one that is running.
> > >
> > > Run "modinfo" on openvswitch_mod.ko and on a module built for the
> > > running kernel, e.g.:
> > >
> > > % /sbin/modinfo openvswitch_mod.ko
> > > % /sbin/modinfo /lib/modules/`uname -r`/kernel/net/bridge/bridge.ko
> > >
> > > Compare the "vermagic" lines output by the two commands.  If they
> > > differ, then Open vSwitch was built for the wrong kernel.
> > >
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://openvswitch.org/pipermail/discuss/attachments/20110526/a0524883/attachment-0001.htm>


More information about the discuss mailing list