[ovs-discuss] OVS controller reconnection on XenServer reboot

David Erickson derickso at stanford.edu
Tue May 3 04:10:02 UTC 2011


On 5/2/2011 7:09 PM, Justin Pettit wrote:
> On May 2, 2011, at 3:00 PM, Ben Pfaff wrote:
>
>> On Mon, May 02, 2011 at 02:51:14PM -0700, David Erickson wrote:
>>> I've noticed that OVS isn't connecting to the controller on
>>> boot/reboot, is there an option somewhere I need to set to enable
>>> this?  On further inspection when I run ovs-vsctl list bridge it
>>> looks like the bridge lost both its controller entry and its
>>> other_config:datapath-id.  Is there a persist or save command I need
>>> to issue after setting these things?
>> What happens at boot is this:
>>
>> 	* OVS tears down and destroys all bridges, because XenServer
>>           expects to re-create each one at boot.
>>
>> 	* OVS refreshes the manager (OVSDB connection) from the
>>           XenServer (XAPI) database.
>>
>> 	* XenServer creates each of the bridges.  No controller is
>>           set.
>>
>> 	* The manager is supposed to set the controller for each
>>           bridge as it likes, using the OVSDB connection to do so.
> I answered a very similar question a couple of weeks ago, and described a couple different possible solutions:
>
> 	http://openvswitch.org/pipermail/discuss/2011-April/005080.html
>

Ah sorry for the duplicate, but I appreciate the reply.  I'm unfamiliar 
with the manager, is there a pointer or further information on what it 
does/how it works?

Thanks,
David






More information about the discuss mailing list