[ovs-discuss] using routers to separate networks

Tom Brown nextstate at gmail.com
Wed May 4 23:35:19 UTC 2011


On Wed, May 4, 2011 at 11:47, Ben Pfaff <blp at nicira.com> wrote:

> On Wed, May 04, 2011 at 11:36:20AM -0700, Tom Brown wrote:
> > On Wed, May 4, 2011 at 11:00, Ben Pfaff <blp at nicira.com> wrote:
> >
> > > On Tue, May 03, 2011 at 05:37:45PM -0700, Tom Brown wrote:
> > > > Each vm in the network is supposed to sit behind a router and use
> dhcp to
> > > > obtain an ip address from the dhcp server running on the router.
> However,
> > > > I'm finding that the dhcp request coming out of the vms is seen by
> dhcp
> > > > server on the host machine's network (our company dhcp server).
> > >
> > > Looking at your diagram, the only connections from each vm to the
> > > "outside world" are through a router or a br network device.  To me
> > > this suggests a few possibilities:
> > >
> > >        * The br network devices are forwarding the DHCP requests.
> > >
> > Thanks for your reply. I believe the issue to be that the br network
> devices
> > are forwarding the DHCP requests. I'm not doing anything with the router
> > that would forward broadcast/DHCP packets. There are no additional
> network
> > devices not shown in the diagram.
> >
> > I wasn't expecting the br devices to forward the DHCP requests through
> br0.
> > How do I prevent that from happening?
>
> I wouldn't expect it to forward them, either.  DHCP requests are
> normally addressed to 255.255.255.255, which should not be forwarded.
>
> Do you have an IP address configured on br0 or br1?  If you don't,
> then you can just "ifconfig br0 down".  If this makes a difference,
> then it at least proves that br0 is responsible for forwarding the
> request, for whatever reason.
>

Ah. I found the issue. I was not setting vlan=n for each -net configuration
for my router on the qemu-kvm command-line. So, now I two separate virtual
networks behind virtual routers. They vms are now getting their ips from the
dhcp server in the associated router.

Thanks!
Tom
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://openvswitch.org/pipermail/ovs-discuss/attachments/20110504/7b76d5f0/attachment.html>


More information about the discuss mailing list