[ovs-discuss] error message with connection to openflow controller

ahmad numan numan252 at gmail.com
Thu May 26 18:07:43 UTC 2011

I think NOX error message is also related to buffer_id. My switch is
connected to a larger network and error message starts just after connecting
to openflow controller. What can be the solution for this error message.
Ahmed Bilal

On Thu, May 26, 2011 at 10:42 PM, Ben Pfaff <blp at nicira.com> wrote:

> On Thu, May 26, 2011 at 10:30:46PM +0500, ahmad numan wrote:
> > I setup  OVS on a machine (loaded kernel module, setup ovs-vswitchd and
> > bridges etc.)and connect to an out-of-band NOX controller using
> > ovs-openflowd. Controller got connected and switch is working correct
> > (machines are pinging each other and netperf is also working correctly in
> > openflow network). But i got error message after connecting with
> controller
> > such as "attempt to reuse the buffer" in ovs-openflowd terminal . NOX
> > controller terminal is also showing error message "received openflow
> error
> > packets for dpid XXXXXXXXX type=1 code=7". Moreover when i tried to
> manage
> > the openflow traffic using "ovs-ofctl" i got error message "fail to
> delete
> > flow" in ovs-openflowd terminal.
> >
> > What do these error messages indicate ? is there any error in
> configuration
> > or something else?
> "Attempt to reuse buffer" means that the controller has tried to use
> the same buffer_id in two or more OpenFlow requests.  That doesn't
> work, because the first use of a buffer_id causes the buffer to be
> freed so that it can be reused for new packets coming in.
> I don't know why "ovs-ofctl" would report that error.  Can you show
> the whole ovs-ofctl output?  Add "-vvconn" to the command line to get
> more debugging output.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://openvswitch.org/pipermail/ovs-discuss/attachments/20110526/b58bf07c/attachment.html>

More information about the discuss mailing list