[ovs-discuss] Packet Out with mod_dl_dst results in packets disappearing.

Jari Sundell sundell.software at gmail.com
Tue Nov 1 11:04:09 UTC 2011


On Tue, Nov 1, 2011 at 2:47 AM, Ben Pfaff <blp at nicira.com> wrote:
> On Mon, Oct 31, 2011 at 03:37:53PM +0900, Jari Sundell wrote:
>> While working on a project I encountered some weird behavior, which
>> I'm unsure if is a bug or a mistake on my part. (Running on ovs pulled
>> from git a week or so ago)
>>
>> The controller attempts pass a packet to OFPP_LOCAL, with instructions
>> to rewrite dl_dst, nw_dst and tp_dst. However it seems to only work
>> for the latter two, so when the dl_dst action is included the packet
>> never shows up. Even using OFPP_FLOOD, etc, gives nothing.
>
> Hmm, in simple tests mod_dl_dst works OK for me.  Can you give a more
> specific recipe for reproducing the problem?

Well, tried it again with latest git and it happened, however 1.2.2
did not produce that issue.

It is not really that easy to provide a recipe, as a lot of different
things were tried and only the downgrade made any difference. And now
that I moved back to git master it works again as it is supposed to,
so even I can't reproduce it.

Jari Sundell



More information about the discuss mailing list