[ovs-discuss] GRE tunneling questions

JC Martin jch.martin at gmail.com
Wed Nov 2 22:47:04 UTC 2011

When it doesn't work I have a host unreachable while trying to ping a device on the 192.168.200.x. I see that the icmp packets are routed to the right interface (the one attached to the bridge with the tunnel, with the IP=, but it seems that the tunnel is too long to see its end:

root at bm-1:~# ping
PING ( 56(84) bytes of data.
From icmp_seq=2 Destination Host Unreachable
From icmp_seq=3 Destination Host Unreachable
From icmp_seq=4 Destination Host Unreachable
From icmp_seq=5 Destination Host Unreachable
From icmp_seq=6 Destination Host Unreachable
From icmp_seq=7 Destination Host Unreachable

On Nov 2, 2011, at 10:16 AM, Jesse Gross wrote:

> On Wed, Nov 2, 2011 at 10:09 AM, JC Martin <jch.martin at gmail.com> wrote:
>>  gre1 was built with the following command:
>>  [root at xcp-2 ~]# ovs-vsctl add-port xapi1 gre1 -- set interface gre1 type=gre options:remote_ip=
>>  I tried to replicate the xenserver setup on bm-1 by adding a bridge with eth0 as a port, adding another bridge with the tunnel and an interface, but it has not been successful (i tried also with only one bridge with the tunnel and an interface). Ideally, on bm-1 I would like to have two interfaces, one on 172.16.188.x and one on my private network (192.168.200.x)
> That should be fine as long as bm-1 is reachable on
> What do you see when it doesn't work?

More information about the discuss mailing list