[ovs-discuss] help: test-openflowd and system at dp1: execute 1 failed (Invalid argument)

ztom switch.tom at hotmail.com
Wed Nov 30 07:05:19 UTC 2011


the br is equal to dp0 ($ ovs-dpctl add-dp dp0)? and i use the NOX as the controller. Could you give me a example?

my case: step1. ovs-dpctl add-dp dp0
                step2. ./test-openflowd dp0 tcp:127.0.0.1
                            & ./nox_core -v -i ptcp:6633 monitoring
                then i can get some info about dp0 with nox's gui    

> Date: Tue, 29 Nov 2011 22:49:37 -0800
> From: blp at nicira.com
> To: switch.tom at hotmail.com
> CC: discuss at openvswitch.org
> Subject: Re: [ovs-discuss] help: test-openflowd and system at dp1: execute 1 failed (Invalid argument)
> 
> Read the documentation.  You can start with "ovs-vsctl add-br" and
> "ovs-vsctl set-controller".
> 
> On Wed, Nov 30, 2011 at 02:52:13PM +0800, ztom wrote:
> > 
> > $ ./test-openflowd dp0 tcp: x.x.x.x  //the dp0 is looked as an openflow switch, and it links to the controller(x.x.x.x)
> > but now using ovs-vswitchd, i don't know what's the cmd. ovs-vswitchd ???  i can't find anything about datapath with ovs-vswitchd help.
> > 
> > 
> > > Date: Tue, 29 Nov 2011 22:34:53 -0800
> > > From: blp at nicira.com
> > > To: switch.tom at hotmail.com
> > > CC: discuss at openvswitch.org
> > > Subject: Re: [ovs-discuss] help: test-openflowd and system at dp1: execute 1 failed (Invalid argument)
> > > 
> > > On Wed, Nov 30, 2011 at 02:38:09PM +0800, ztom wrote:
> > > > i need to do some tests with the openflow vswitch, but now there's no
> > > > "test-openflowd" script. What should i do?
> > > 
> > > Use ovs-vswitchd.
> >  		 	   		  
 		 	   		  
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://openvswitch.org/pipermail/ovs-discuss/attachments/20111130/254a704d/attachment.html>


More information about the discuss mailing list