[ovs-discuss] Bad OpenFlow buffer IDs, etc.

Murphy McCauley murphy.mccauley at gmail.com
Mon Oct 17 19:38:17 UTC 2011

Most tests pass here too.  Exceptions are:
110: ovs-ofctl dump-flows honors -F option         (ovs-ofctl.at:500)
565: strings at least 2 characters long - Python   (ovsdb-data.at:458)
933: --id option on create, get commands           (ovs-vsctl.at:816)

The problem with buffer IDs is in ofputil_encode_packet_in() which
writes to an unaligned ofp_packet_in pointer.

Any thoughts on a good way to fix this, or how to locate other places
where the same thing may be happening (there's no warning or anything)?

-- Murphy

On Mon, 2011-10-17 at 07:52 -0700, Ben Pfaff wrote:
> On Mon, Oct 17, 2011 at 07:09:15AM -0700, Murphy McCauley wrote:
> > I've got some problems with Open vSwitch on a little ARM-based machine
> > (32 bit, little endian).  I've tried to set it up exactly the same as I
> > have on x86, but I'm getting somewhat different (and problematic)
> > results.
> What version of OVS are you using?  I'll note that Open vSwitch 1.2.1
> passed the testsuite on armel:
>         https://buildd.debian.org/status/package.php?p=openvswitch&suite=sid
> whereas I haven't tried the Git master version on a RISC architecture in
> ages.
> The testsuite wouldn't necessarily find a problem, but it's still a good
> start.

More information about the discuss mailing list