[ovs-discuss] When is Bridge Compatibility not needed?

Umair Hoodbhoy umairhoodbhoy at gmail.com
Mon Dec 10 08:57:09 UTC 2012


Thanks. So would OVS 1.4.0 (Ubuntu package) require ovs-brcompat to be
installed? My goal is to implement VLAN Configuration as per the Cookbook
on the website.


-- Umair



On Mon, Dec 10, 2012 at 12:31 AM, Justin Pettit <jpettit at nicira.com> wrote:

> On Dec 10, 2012, at 12:22 AM, Umair Hoodbhoy <umairhoodbhoy at gmail.com>
> wrote:
>
> > Does this mean that if you do *not* have Linux 3.3 or later (e.g. you
> have 3.2), then you don't need ovs-brcompatd?
>
> It's simply stating that bridge compatibility will not work with the
> upstream kernel module.
>
> > Also, under which circumstances would someone not need bridge
> compatibility in an OVS world?
>
> The only reason to use bridge compatibility is if you have integration
> scripts that are expecting to interact with the Linux bridge.  OVS is
> widely supported enough that that's generally not need any more.  In fact,
> the next version of OVS will likely drop bridge compatibility completely.
>
> --Justin
>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://openvswitch.org/pipermail/ovs-discuss/attachments/20121210/e3b2cf3b/attachment.html>


More information about the discuss mailing list