[ovs-discuss] High CPU usage due to L3/4 flows

Bernhard Schmidt berni at birkenwald.de
Mon Dec 10 23:03:27 UTC 2012


Am 07.12.2012 23:33, schrieb Brad Hedlund:

Hi Brad,

> Out of curiosity, have you tried using the *ovs-controller*?
>
> http://openvswitch.org/cgi-bin/ovsman.cgi?page=utilities%2Fovs-controller.8

Thanks, this sounds like the thing I was looking for.

Unfortunately, I could not quite get it to work.

I started "ovs-controller ptcp:" and entered

ovs-vsctl set-controller tcp:127.0.0.1

This lead to a short network meltdown as ovs-controller apparently could 
not deal with the active-standby bond uplink and created a loop with a 
broadcast storm. Fortunately I had some fallbacks in place to shutdown 
one port out-of-band quickly, otherwise it would have become quite 
interesting.

I shut down one of the ports and tried again. It seems to work, but I 
don't get any connectivity. With "-v" my console gets flooded with 
flows, which result in action=FLOOD

Dec 10 22:53:43|00583|vconn|DBG|tcp:127.0.0.1:33073: received: 
OFPT_PACKET_IN (xid=0x0): total_len=118 in_port=1 data_len=118 (unbuffered)
priority0:tunnel0:in_port0001:tci(vlan15,pcp0) 
mac00:22:55:11:bb:00->00:16:3e:2c:e6:a1 type0800 proto17 tos0 ttl119 
ip1.2.3.4->5.4.3.2 port49210->58698
Dec 10 22:53:43|00584|vconn|DBG|tcp:127.0.0.1:33073: sent (Success): 
OFPT_PACKET_OUT (xid=0x0): in_port=1 actions_len=8 actions=FLOOD 
data_len=118

But I don't gain connectivity to either the management or any VM until I 
switch back to ovs-vswitchd. And it doesn't seem to learn a lot either, 
at least I could not see anything without action=FLOOD in the logs at 
all. There are a few log messages like

Dec 10 22:53:54|00918|learning_switch|DBG|0000001517db6266: learned that 
40:61:86:30:7b:36 is on port 1

but I cannot see them used.


But basically the mask feature would be exactly the thing I need in 
ovs-vswitchd :-\

Bernhard



More information about the discuss mailing list