[ovs-discuss] Port number is not appear on ovs-ofctl show

Diego Rivero riverod9 at gmail.com
Tue Dec 18 08:05:59 UTC 2012


Hi,

I am now facing some problem while working on GRE over IPsec with Open
vSwitch version 1.6.1. "ovs-ofctl show br1" does not show any port number
for ipsec_gre, so I cannot set up flows for ipsec packets. Only tap1 that
is activated for a kvm instance is shown on the prompt. Does anybody know
how to make it through?



# ovs-vsctl add-br br1
# ovs-vsctl add-port br1 tap1
# ovs-vsctl add-port br1 gre1
# ovs-vsctl set interface gre1 type=gre options:remote_ip=192.168.2.25

# ovs-ofctl show br1
OFPT_FEATURES_REPLY (xid=0x1): ver:0x1, dpid:0000aea6970c5149
n_tables:255, n_buffers:256
features: capabilities:0xc7, actions:0xfff
 3(tap1): addr:9e:59:be:c9:f5:a6
     config:     0
     state:      0
     current:    10MB-FD COPPER
 9(gre1): addr:de:25:2e:36:dc:55
     config:     0
     state:      0
 LOCAL(br1): addr:ae:a6:97:0c:51:49
     config:     0
     state:      0
OFPT_GET_CONFIG_REPLY (xid=0x3): frags=normal miss_send_len=0




# ovs-vsctl set interface gre1 type=ipsec_gre options:peer_cert=peer.pem
options:certificate=cert.pem options:psk=testpsk

# ovs-ofctl show br1
OFPT_FEATURES_REPLY (xid=0x1): ver:0x1, dpid:0000aea6970c5149
n_tables:255, n_buffers:256
features: capabilities:0xc7, actions:0xfff
 3(tap1): addr:9e:59:be:c9:f5:a6
     config:     0
     state:      0
     current:    10MB-FD COPPER
 LOCAL(br1): addr:ae:a6:97:0c:51:49
     config:     0
     state:      0
OFPT_GET_CONFIG_REPLY (xid=0x3): frags=normal miss_send_len=0





# ovs-vsctl set interface gre1 type=capwap

root at zenra:~/ovs# ovs-ofctl show br1
OFPT_FEATURES_REPLY (xid=0x1): ver:0x1, dpid:0000aea6970c5149
n_tables:255, n_buffers:256
features: capabilities:0xc7, actions:0xfff
 3(tap1): addr:9e:59:be:c9:f5:a6
     config:     0
     state:      0
     current:    10MB-FD COPPER
 10(gre1): addr:aa:70:f5:39:4b:2c
     config:     0
     state:      0
 LOCAL(br1): addr:ae:a6:97:0c:51:49
     config:     0
     state:      0
OFPT_GET_CONFIG_REPLY (xid=0x3): frags=normal miss_send_len=0



# ovs-vsctl add-port br1 tap2
# ovs-ofctl show br1
OFPT_FEATURES_REPLY (xid=0x1): ver:0x1, dpid:0000aea6970c5149
n_tables:255, n_buffers:256
features: capabilities:0xc7, actions:0xfff
 3(tap1): addr:9e:59:be:c9:f5:a6
     config:     0
     state:      0
     current:    10MB-FD COPPER
 LOCAL(br1): addr:ae:a6:97:0c:51:49
     config:     0
     state:      0
OFPT_GET_CONFIG_REPLY (xid=0x3): frags=normal miss_send_len=0




Thanks,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://openvswitch.org/pipermail/ovs-discuss/attachments/20121218/be87b763/attachment.html>


More information about the discuss mailing list