[ovs-discuss] Transitivity of Openvswitch connections.

Jesse Gross jesse at nicira.com
Mon Dec 31 20:50:50 UTC 2012


On Sat, Dec 29, 2012 at 11:26 PM, Saul St. John <sstjohn at cs.wisc.edu> wrote:
> On 12/29/2012 07:43 PM, Ben Pfaff wrote:
>> On Sat, Dec 29, 2012 at 06:38:17PM -0600, Anand Krishnamurthy wrote:
>>> 2012-12-30T00:22:49Z|49582|dpif|WARN|system at ovs-system: failed to flow_del (No such file or directory) ipv4_tunnel(tun_id=0x0,src=172.19.0.42,dst=172.19.0.41,tos=0x0,ttl=64,flags()),in_port(5),eth(src=76:e8:f3:9f:95:a6,dst=01:80:c2:00:00:0e),eth_type(0x88cc)
>>> 2012-12-30T00:22:50Z|49583|ofproto_dpif|WARN|Dropped 3 log messages in last 45 seconds (most recently, 15 seconds ago) due to excessive rate
>>> 2012-12-30T00:22:50Z|49584|ofproto_dpif|WARN|unexpected flow on br0: ipv4_tunnel(tun_id=0x0,src=172.19.0.42,dst=172.19.0.41,tos=0x0,ttl=64,flags()),in_port(5),eth(src=76:e8:f3:9f:95:a6,dst=01:80:c2:00:00:0e),eth_type(0x88cc)
>> The above errors indicate a bug in Open vSwitch.  Their form indicates
>> that you must be using a recent build from master.  What commit are you
>> running?
>
> We're using a build from commit a4454ac. I ran some other tests on the
> strange behavior we've been seeing with this build that might be
> related, deets below and in attachments.
>
> (tl;dr: ovswitches are failing to forward traffic from one GRE interface
> to another GRE interface correctly, but succeeds when a patch-pair is
> interposed between the tunnels.)

Thanks for the bug report.  There are a number of tunneling changes
going into master at the moment so you hit a few issues in code that
just went in.  I sent out a pair of patches and CC'ed you guys that
I'm pretty sure will fix the problems if you want to test them.



More information about the discuss mailing list