[ovs-discuss] ovs-brcompatd on CentOS/RHEL 6.x

Frido Roose fr.roose at gmail.com
Fri Feb 3 11:02:36 UTC 2012


I did some more tests, and so far it looks it's only the brctl show that
has this problem.

# brctl show
bridge name bridge id STP enabled interfaces
vbr314 /sys/class/net/vbr314/bridge: No such file or directory
/sys/class/net/vbr314/bridge: No such file or directory
/sys/class/net/vbr314/bridge: No such file or directory
/sys/class/net/vbr314/bridge: No such file or directory
/sys/class/net/vbr314/bridge: No such file or directory
/sys/class/net/vbr314/bridge: No such file or directory
/sys/class/net/vbr314/bridge: No such file or directory
/sys/class/net/vbr314/bridge: No such file or directory
/sys/class/net/vbr314/bridge: No such file or directory
/sys/class/net/vbr314/bridge: No such file or directory
/sys/class/net/vbr314/bridge: No such file or directory
/sys/class/net/vbr314/bridge: No such file or directory
0000.e41f131c4a08 no bond0.314
vnet0
vbr315 /sys/class/net/vbr315/bridge: No such file or directory
/sys/class/net/vbr315/bridge: No such file or directory
/sys/class/net/vbr315/bridge: No such file or directory
/sys/class/net/vbr315/bridge: No such file or directory
/sys/class/net/vbr315/bridge: No such file or directory
/sys/class/net/vbr315/bridge: No such file or directory
/sys/class/net/vbr315/bridge: No such file or directory
/sys/class/net/vbr315/bridge: No such file or directory
/sys/class/net/vbr315/bridge: No such file or directory
/sys/class/net/vbr315/bridge: No such file or directory
/sys/class/net/vbr315/bridge: No such file or directory
/sys/class/net/vbr315/bridge: No such file or directory
0000.e41f131c4a08 no bond0.315

But if you filter the errors with: # brctl show 2>/dev/null
bridge name bridge id STP enabled interfaces
vbr314 0000.e41f131c4a08 no bond0.314
vnet0
vbr315 0000.e41f131c4a08 no bond0.315

The output looks fine (vnet0 is bound to the vbr314 bridge), so this is
probably a minor issue.

Best regards,
Frido


On Wed, Feb 1, 2012 at 6:58 PM, Ben Pfaff <blp at nicira.com> wrote:

> Is it only "brctl show" that has problems, or do other brctl commands
> have problems too?
>
> On Wed, Feb 01, 2012 at 12:03:06PM +0100, Frido Roose wrote:
> > It definitely has to do with the version of the bridge utils.  I
> recompiled
> > the bridge-utils included with Centos 5.7
> (bridge-utils-1.1-3.el5.src.rpm)
> > for Centos 6.2.
> > Works perfectly now:
> >
> > # brctl show
> > bridge name bridge id STP enabled interfaces
> > vbr314 0000.e41f131c3efc no bond0.314
> > vnet0
> > vbr315 0000.e41f131c3efc no bond0.315
> >
> > It would be nice however if it would work with the default bridge-utils
> > version (bridge-utils-1.2-9.el6.x86_64).
> >
> > Best regards,
> > Frido
> >
> >
> > On Tue, Jan 31, 2012 at 6:30 PM, Ben Pfaff <blp at nicira.com> wrote:
> >
> > > On Tue, Jan 31, 2012 at 10:21:46AM +0100, Frido Roose wrote:
> > > > I'm currently trying openvswitch in a KVM environment on CentOS 6.2,
> and
> > > > I'm having a problem with the compatibility mode when running
> > > ovs-brcompatd.
> > > >
> > > > # ovs-vsctl add-br vbr314
> > > > # brctl show
> > > > bridge name bridge id STP enabled interfaces
> > > > vbr314 /sys/class/net/vbr314/bridge: No such file or directory
> > > > /sys/class/net/vbr314/bridge: No such file or directory
> > > > /sys/class/net/vbr314/bridge: No such file or directory
> > > > /sys/class/net/vbr314/bridge: No such file or directory
> > > > /sys/class/net/vbr314/bridge: No such file or directory
> > > > /sys/class/net/vbr314/bridge: No such file or directory
> > > > /sys/class/net/vbr314/bridge: No such file or directory
> > > > /sys/class/net/vbr314/bridge: No such file or directory
> > > > /sys/class/net/vbr314/bridge: No such file or directory
> > > > /sys/class/net/vbr314/bridge: No such file or directory
> > > > /sys/class/net/vbr314/bridge: No such file or directory
> > > > /sys/class/net/vbr314/bridge: No such file or directory
> > > > 0000.cade601c144d no
> > > >
> > > > I've read somewhere on the net that the bridge tools in RHEL 6.x are
> too
> > > > recent.  Are there any workarounds, or is an update on this planned
> for a
> > > > coming release?
> > >
> > > What version of the bridge tools do you have?
> > >
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://openvswitch.org/pipermail/ovs-discuss/attachments/20120203/055f0329/attachment.html>


More information about the discuss mailing list