[ovs-discuss] how to enable inband communication

sachin sharma sharon_sachin at yahoo.co.in
Sun Feb 19 22:48:58 UTC 2012


Hi Ben,
My problem is that I am not able to establish the connection between the controller and the Open Vswitch switches which are not directly connected. In addition to the commands written in INSTALL.Linux, I just added the set-controller command to the br0 datapath,  However, this is enabling out-of-band communication.  I am saying this because I am not able to see the controller traffic from the ethernet ports which I have added to the datapath unit (br0 in our cases).  


I will explain my problem with the help of following setup:


A (eth1) --------------- (eth1)B(eth2)-------------(eth1)Controller

A and B are Open vSwitches in above diagram.  Let the IP address of eth1 at the controller is 192.168.1.1. 


In A, I have added eth1 port in br0 datapath as explained in INSTALL.Linux. then I added the controller by following command:
ovs-vsctl set-controller br0 tcp:192.168.1.1:6633

In B, I have run same commands ie added eth1 port of B as datapath port. and again setted controller.

In B, I am able to see the connection with the controller, established by netstat command!. 

It is going through eth2 which have not been added in br0 of B. It is going through following routing entry in B.
192.168.1.0      *               255.255.255.0   U     0      0        0 eth2

But the Open vSwitch A is not able to establish the connection with the controller which I was expecting from eth1?

I was expecting that the openvswitch A would search the controller by sending ARP messages and would then add the hidden flows for the controller traffic. However, this is not happening.
However, this is not happening?

Thanks,





________________________________
 From: Ben Pfaff <blp at nicira.com>
To: sachin sharma <sharon_sachin at yahoo.co.in> 
Cc: "discuss at openvswitch.org" <discuss at openvswitch.org> 
Sent: Sunday, 19 February 2012 8:41 PM
Subject: Re: [ovs-discuss] how to enable inband communication
 
No, no additional setup should be necessary.  It's not obvious to me
what your problem is.

On Sun, Feb 19, 2012 at 04:33:46PM +0530, sachin sharma wrote:
> Hi Ben,
> Do I also need to enable in-band stuff at the datapath ports as well?   I just added the datapath port as explained in INSTALL.Linux and then setted up the controller as you explained in last mail.  I am not observing any packet exchange in the tcpdump output of datapath ports.   My set up is =>  switch A, B and C connected in a linear way and the controller is connected to switch B. So in this setup, I am interested that the controller traffic of the switch A and C should go via datapath ports connected to switch B. 
> 
> 
> thanks,
> Sachin
> 
> 
> 
> ________________________________
>  From: Ben Pfaff <blp at nicira.com>
> To: sachin sharma <sharon_sachin at yahoo.co.in> 
> Cc: "discuss at openvswitch.org" <discuss at openvswitch.org> 
> Sent: Wednesday, 15 February 2012 6:04 PM
> Subject: Re: [ovs-discuss] how to enable inband communication
>  
> On Wed, Feb 15, 2012 at 08:02:05PM +0530, sachin sharma wrote:
> > I found the design of inband communication at openvswitch via DESIGN
> > file in the openvswitch. However, i did not find the exact steps to
> > configure this in our switches.
> 
> In-band control is enabled by default when you configure a controller.
> You can use "ovs-vsctl set-controller <bridge> <controller>" to
> configure a controller.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://openvswitch.org/pipermail/ovs-discuss/attachments/20120220/ec6f3dc6/attachment.html>


More information about the discuss mailing list