No subject

Fri Jun 29 21:31:54 UTC 2012

Kindly guide me to find a solution to this issue which has been haunting me=
 for days together :-(

Thanks & Kind Regards=2C
Ashraf Khalid 		 	   		  =

Content-Type: text/html; charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

.hmmessage P
font-size: 12pt=3B
<body class=3D'hmmessage'><div dir=3D'ltr'>Hi Ben=2C<br><br>I have tied the=
 steps and reference you had given=2C but failed. I had rephrased the query=
 with the changes I have tried=2C and the learning I have had after your he=
lp.<br><br>Please find those commands being executed as part of that mail i=
tself.&nbsp=3B <i>-- see below</i> <br><br>Assigning IP address to the port=
 (vlan1200) created under the main bridge (cloudbr) is failing. Now after a=
 machine restart and trying the same configuration and commands=2C it pings=
 the gateway address for a while=2C<font style=3D"" color=3D"#D24726"> and =
then it fails</font>.<br><br>I request you to please go through the complet=
e mail (<i>-- see below</i>) to understand the whole scenario=2C and help m=
e to pin out where I am going wrong. Thanks!<br><br>Thanks &amp=3B Regards=
=2C<br>Ashraf Khalid<br><br><br>=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D=3D=3D<br><br><div>Dear friends=2C<br><br>I have not found a=
 solution yet=2C and feels it is a matter of some basic config error. Kindl=
y help!<br><br>Let me rephrase the scenario again:<br><br><font style=3D"" =
color=3D"#D24726"><b>I want to know procedure to setup bridge on top of an =
existing bond interface which is configured using linux native bonding.</b>=
</font><font style=3D"" color=3D"#D24726"><br></font><br><font style=3D"" c=
olor=3D"#008A17">I have configured "<b>bond0</b>"=0A=
 bond interface using eth1 and eth2 using mode=3D4 (alb) in the CentOS 6.4=
 host=2C and LACP configured in the physical switches (stacked). <br><br>La=
ter I tested it by assigning an IP address to the bond0 bond interface=2C a=
nd it seems to be working just fine! </font><font style=3D"" color=3D"#008A=
17">I could successfully ping the default gateway.</font><br><br>Please not=
e that the physical switch ports to which eth1 &amp=3B eth2 are connected i=
s configured as access ports for <b>VLAN 1200</b>.<br><br>Later=0A=
 I removed the IP Address from bond interface (bond0) which I had =0A=
created (but retained the bonding configurations in the =0A=
/etc/sysconfig/network-scripts/ifcfg-bond0 ).<br><br>Now I want to create a=
 main bridge named "<b>cloudbr</b>" using open vswitch on top of this nativ=
e linux bond interface (bond0)=2C&nbsp=3B and finally create an internal po=
rt named "<b>vlan1200</b>"=2C assign an IP address to it=2C so as to connec=
t from externally for management purpose.<br><br>I have tried the same usin=
g ovs-vsctl command=2C but it is succeeds only for a brief moment=2C and th=
en fails. Please find the commands I had executed:<br><br><b><span style=3D=
=2C&quot=3Bsans-serif&quot=3B=3B"># ovs-vsctl add-br cloudbr<br></span><spa=
n style=3D"font-size:11.0pt=3Bline-height:115%=3Bfont-family:&quot=3BCalibr=
i&quot=3B=2C&quot=3Bsans-serif&quot=3B=3B"># ovs-vsctl add-port cloudbr bon=
d0 tag=3D1200 vlan_mode=3Daccess<br></span><span style=3D"font-size:11.0pt=
rif&quot=3B=3B"># ovs-vsctl add-port cloudbr vlan1200 tag=3D1200 </span><sp=
an style=3D"font-size:11.0pt=3Bline-height:115%=3Bfont-family:&quot=3BCalib=
ri&quot=3B=2C&quot=3Bsans-serif&quot=3B=3B"></span>-- set interface vlan120=
0 type=3Dinternal</b><span style=3D"font-size:11.0pt=3Bline-height:115%=3Bf=
# ifconfig vlan1200 netmask broadcast 192.168=
.120.255 up<br># ovs-vsctl show<br></b>01c9bfe9-8d4b-4d9e-bf5c-a0be244583d9=
<br>&nbsp=3B&nbsp=3B&nbsp=3B Bridge cloudbr<br>&nbsp=3B&nbsp=3B&nbsp=3B&nbs=
p=3B&nbsp=3B&nbsp=3B&nbsp=3B Port "bond0"<br>&nbsp=3B&nbsp=3B&nbsp=3B&nbsp=
=3B&nbsp=3B&nbsp=3B&nbsp=3B&nbsp=3B&nbsp=3B&nbsp=3B&nbsp=3B tag: 1200<br>&n=
=3B&nbsp=3B Interface "bond0"<br>&nbsp=3B&nbsp=3B&nbsp=3B&nbsp=3B&nbsp=3B&n=
bsp=3B&nbsp=3B Port cloudbr<br>&nbsp=3B&nbsp=3B&nbsp=3B&nbsp=3B&nbsp=3B&nbs=
p=3B&nbsp=3B&nbsp=3B&nbsp=3B&nbsp=3B&nbsp=3B Interface cloudbr<br>&nbsp=3B&=
p=3B&nbsp=3B&nbsp=3B&nbsp=3B&nbsp=3B type: internal<br>&nbsp=3B&nbsp=3B&nbs=
p=3B&nbsp=3B&nbsp=3B&nbsp=3B&nbsp=3B Port "vlan1200"<br>&nbsp=3B&nbsp=3B&nb=
sp=3B&nbsp=3B&nbsp=3B&nbsp=3B&nbsp=3B&nbsp=3B&nbsp=3B&nbsp=3B&nbsp=3B tag: =
sp=3B&nbsp=3B&nbsp=3B Interface "vlan1200"<br>&nbsp=3B&nbsp=3B&nbsp=3B&nbsp=
&nbsp=3B&nbsp=3B type: internal<br>&nbsp=3B&nbsp=3B&nbsp=3B ovs_version: "1=
.10.0"<br><br><b># ping </b><i>(trying to ping the default ga=
teway)</i><br><font style=3D"" color=3D"#008A17">PING (192.16=
8.120.1) 56(84) bytes of data.</font><font style=3D"" color=3D"#008A17"><br=
></font><font style=3D"" color=3D"#008A17">64 bytes from icm=
p_seq=3D2 ttl=3D255 time=3D0.534 ms</font><font style=3D"" color=3D"#008A17=
"><br></font><font style=3D"" color=3D"#008A17">64 bytes from
: icmp_seq=3D3 ttl=3D255 time=3D0.462 ms</font><font style=3D"" color=3D"#0=
08A17"><br></font><font style=3D"" color=3D"#008A17">64 bytes from 192.168.=
120.1: icmp_seq=3D4 ttl=3D255 time=3D0.462 ms</font><font style=3D"" color=
=3D"#008A17"><br></font><font style=3D"" color=3D"#008A17">64 bytes from 19= icmp_seq=3D5 ttl=3D255 time=3D0.452 ms</font><font style=3D"" =
color=3D"#008A17"><br></font><font style=3D"" color=3D"#008A17">64 bytes fr=
om icmp_seq=3D6 ttl=3D255 time=3D0.455 ms</font><br>........=
...<br>...........<br>...........<br><font style=3D"" color=3D"#D24726">Fro=
m icmp_seq=3D35 Destination Host Unreachable</font><font st=
yle=3D"" color=3D"#D24726"><br></font><font style=3D"" color=3D"#D24726">Fr=
om icmp_seq=3D36 Destination Host Unreachable</font><font s=
tyle=3D"" color=3D"#D24726"><br></font><font style=3D"" color=3D"#D24726">F=
rom icmp_seq=3D37 Destination Host Unreachable</font><font =
style=3D"" color=3D"#D24726"><br></font><font style=3D"" color=3D"#D24726">=

More information about the discuss mailing list