[ovs-discuss] Problem adding eth0 as port (device busy)

Bjørnar Ness bjornar.ness at gmail.com
Wed May 9 18:16:26 UTC 2012


Using OVS 1.4.1 and kernel 3.3.5 with OVS

OVS running in kvm, trying to add eth0 as a port on bridge0
with no success. No other bridge running.

Log messages:

May  9 19:57:49 debian01 ovs-vsctl: 00001|vsctl|INFO|Called as
./bin/ovs-vsctl add-port bridge0 eth0
May  9 19:57:49 debian01 ovs-vswitchd: 01220|bridge|INFO|created port
eth0 on bridge bridge0
May  9 19:57:49 debian01 ovs-vswitchd: 01221|dpif|WARN|system at bridge0:
failed to add eth0 as port: Device or resource busy
May  9 19:57:49 debian01 ovs-vswitchd: 01222|bridge|WARN|eth0 port has
no interfaces, dropping
May  9 19:57:49 debian01 ovs-vswitchd: 01223|bridge|INFO|destroyed port
eth0 on bridge bridge0
May  9 19:57:49 debian01 ovs-vswitchd: 01224|bridge|WARN|bridge bridge0:
using default bridge Ethernet address 22:86:69:43:e9:41
 
 
 
root at debian01:/opt/openvswitch# ./bin/ovs-vsctl del-port bridge0 eth0
root at debian01:/opt/openvswitch# ./bin/ovs-vsctl add-port bridge0 eth0
root at debian01:/opt/openvswitch# ./bin/ovs-dpctl show
system at bridge0:
        lookups: hit:611 missed:44 lost:0
        flows: 0
        port 0: bridge0 (internal)
        port 1: veth563173
 
root at debian01:/opt/openvswitch# ./bin/ovs-vsctl show
744bc837-40fd-46e3-92bf-a3fe9df6abc5
    Bridge "bridge0"
        Port "bridge0"
            Interface "bridge0"
                type: internal
        Port "veth563173"
            Interface "veth563173"
        Port "eth0"
            Interface "eth0"

--
Bjornar



More information about the discuss mailing list