[ovs-discuss] why vm can't ping host eth1

Salman Malik salmanmk at live.com
Fri May 18 02:49:11 UTC 2012


Hi Dongsheng,

Could you please tell me, why do we need to clear up the eth1 IP address? Does it interfere with the bridge ? If yes then how ?
Bridge management is a bit unclear to me so thats why I am asking.

Thanks,
Salman

> From: dongsheng.song at gmail.com
> Date: Fri, 18 May 2012 10:32:23 +0800
> To: heuye.wang at gmail.com
> CC: discuss at openvswitch.org
> Subject: Re: [ovs-discuss] why vm can't ping host eth1
> 
> On Thu, May 17, 2012 at 7:12 PM, yue wang <heuye.wang at gmail.com> wrote:
> >
> > i think vm1/vm2/host are connected to each other by OVS, vm and host should communicate with each other.
> 
> Sure, please see another thread:
> http://openvswitch.org/pipermail/discuss/2012-May/007201.html
> 
> You must clean ALL ip address on eth1, and set the ip address on the
> corresponding bridge device,
> say 'br1', here is a example:
> 
> /usr/bin/ovs-vsctl add-br br1
> /usr/bin/ovs-vsctl add-port br1 eth1
> 
> /sbin/ip addr add ${IP} dev br1
> /sbin/ip link set br1 up
> /sbin/ip address flush dev eth1
> /sbin/ip route replace default via ${GW} # if you have gateway
> corresponding  eth1
> _______________________________________________
> discuss mailing list
> discuss at openvswitch.org
> http://openvswitch.org/mailman/listinfo/discuss
 		 	   		  
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://openvswitch.org/pipermail/ovs-discuss/attachments/20120517/54ab00a7/attachment.html>


More information about the discuss mailing list