[ovs-discuss] Cross-compile to mipsel host

Russ Weeks rweeks at newbrightidea.com
Tue Sep 25 00:35:15 UTC 2012


Hi,

I'm trying to follow the instructions here:
http://www.openflow.org/wk/index.php/UoR_:_Openflow_Kernel_space_on_DD-WRT
regarding
running OpenVSwitch on DD-WRT.  I've run into some problems, and as I fix
them I'm starting to worry that I'm headed down the wrong path.

I've already cross-compiled Linux 2.6.23 for mipsel.  I configure
openvswitch using this command:

./configure \
  --prefix=$OUTPUT_DIR \
  --with-linux=/opt/netgear/ddwrt_src/src/linux/brcm/linux-2.6.23 \
  KARCH=mipsel \
  CC=mipsel-linux-uclibc-gcc \
  AR=mipsel-linux-uclibc-ar \
  LD=mipsel-linux-uclibc-ld \
  RANLIB=mipsel-linux-uclibc-ranlib \
  STRIP=mipsel-linux-uclibc-strip \
  --host=mipsel \
  CFLAGS="-std=gnu99 -g -I${TOOL}/include/
-I/opt/netgear/openvswitch-1.7.1/datapath/linux/compat/include/
-L${TOOL}/lib/" \

where $TOOL=/opt/netgear/tools/toolchain-mipsel_gcc-linaro_uClibc-0.9.32

As soon as I run ./configure, I see the warning:

configure: WARNING: if you wanted to set the --build type, don't use --host.
    If a cross compiler is detected then cross compile mode will be used

Which I've ignored so far.

When I run 'make', the command fails at this step:

mipsel-linux-uclibc-gcc -DHAVE_CONFIG_H -I.   -I ./include -I ./lib -I
./lib   -Wstrict-prototypes -Wall -Wno-sign-compare -Wpointer-arith
-Wdeclaration-after-statement -Wformat-security -Wswitch-enum
-Wunused-parameter -Wstrict-aliasing -Wbad-function-cast -Wcast-align
-Wstrict-prototypes -Wold-style-definition -Wmissing-prototypes
-Wmissing-field-initializers -Wno-override-init  -std=gnu99 -g
-I/opt/netgear/tools/toolchain-mipsel_gcc-linaro_uClibc-0.9.32/include/
-I/opt/netgear/openvswitch-1.7.1/datapath/linux/compat/include/
-L/opt/netgear/tools/toolchain-mipsel_gcc-linaro_uClibc-0.9.32/lib/ -MT
lib/vlandev.o -MD -MP -MF $depbase.Tpo -c -o lib/vlandev.o lib/vlandev.c

with the error:

/opt/netgear/openvswitch-1.7.1/datapath/linux/compat/include/linux/skbuff.h:4:31:
fatal error: linux/skbuff.h: No such file or directory

skbuff.h exists in my project
at /opt/netgear/ddwrt_src/src/linux/brcm/linux-2.6.23/include/linux/skbuff.h,
but adding that include directory results in a different set of warnings
and errors.

Has anybody else been able to cross-compile OpenVSwitch for mipsel?  I'd
love to hear about it.

Thanks,
-Russ
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://openvswitch.org/pipermail/ovs-discuss/attachments/20120924/df69c331/attachment.html>


More information about the discuss mailing list