[ovs-discuss] Unsupported Tunnel type

maryam hanfi mryamhanfi at gmail.com
Fri Feb 8 06:49:16 UTC 2013


I am using OVS-1.7.1 and I tried to add gre0 which is an unsupported type
in OVS. It gives me warning and complains about family not supported. But
when I run ovs-vsctl show command, it list gre0 as port with type gre0 in
the datapath. If type is unknown or protocol is not supported should it not
throw an error and fail to create the port? In this case it just gives the
warning and still adds port to the datapath.

See output below

[root at localhost openvswitch-1.7.1]# ovs-vsctl add-port br1 gre0 -- set
interface gre0 type=gre0 options:remote_ip=

2013-02-07T11:44:15Z|00016|netdev|WARN|could not create netdev gre0 of
unknown type gre0

2013-02-07T11:44:15Z|00017|bridge|WARN|could not open network device gre0
(Address family not supported by protocol)

2013-02-07T11:44:15Z|00018|bridge|WARN|bridge br1: using default bridge
Ethernet address 62:46:d1:07:b7:4e

But ovs-vsctl shows that a port gre0 with type gre0 is been added to br1.

[root at localhost openvswitch-1.7.1]# ovs-vsctl show


    Bridge "br1"

        Port "gre0"

            Interface "gre0"

                type: "gre0"

                options: {remote_ip=""}

        Port "br1"

            Interface "br1"

                type: internal

    Bridge "br0"

        Port "eth0"

            Interface "eth0"

        Port "br0"

            Interface "br0"

                type: internal


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://openvswitch.org/pipermail/ovs-discuss/attachments/20130208/b41a7302/attachment.html>

More information about the discuss mailing list