[ovs-discuss] Openflow problems

anirup dutta anirupdutta at gmail.com
Wed May 8 16:40:30 UTC 2013


I am using Ubuntu 12.04 and openvswitch 1.40. I have three lxc containers
connected to openvswitch bridge say br1. The ip addresses of the 3 lxc
containers are 192.168.1.163(port 2), 192.168.1.164(port
1), 192.168.1.165(port 3). The ip address of the bridge is 192.168.1.208.

I am trying to use the ovs-ofctl command to define my flows.

This is the order of instructions, I executed

sudo ovs-ofctl del-flows br1

This doesn't work
sudo ovs-ofctl add-flow br1
in_port=2,priority=33001,dl_type=0x800,nw_dst=192.168.1.164,actions=output:1
sudo ovs-ofctl add-flow br1
in_port=1,priority=33001,dl_type=0x800,nw_dst=192.168.1.163,actions=output:2
sudo ovs-ofctl add-flow br1
in_port=1,priority=33001,dl_type=0x800,nw_dst=192.168.1.165,actions=output:3

This doesn't work
sudo ovs-ofctl del-flows br1
sudo ovs-ofctl add-flow br1
priority=33001,dl_type=0x800,nw_dst=192.168.1.164,actions=output:1
sudo ovs-ofctl add-flow br1
priority=33001,dl_type=0x800,nw_dst=192.168.1.163,actions=output:2

This works
sudo ovs-ofctl del-flows br1
sudo ovs-ofctl add-flow br1 in_port=2,actions=output:1
sudo ovs-ofctl add-flow br1 in_port=1,actions=output:2


Can anyone point to me the reason why the flow matching based on ip
addresses isn't working.
-- 
Anirup Dutta
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://openvswitch.org/pipermail/ovs-discuss/attachments/20130508/e400d6f1/attachment.html>


More information about the discuss mailing list