[ovs-discuss] Can't obtain IP address for KVM

Flavio Leitner fbl at redhat.com
Sun Mar 30 11:47:27 UTC 2014


On Sat, Mar 29, 2014 at 09:29:08PM -0700, Jeff W wrote:
> 
> BINGO!! Eventually I fixed it!

Glad to hear that!

> It does a conflicting of MAC address! I moved the HWADDR from ifcfg-br0 to ifcfg-eth0, and removed br0 (IMPORTANT!), restart server. every things are now on the way!
> 
> I believe we are experiencing a bug, I actually tried the moving before but it doesn't work until I deleted the bridge and let ovs rebuild it by itself, that's saying, ovs saved the MAC information into database, and not refract changing any more. so remove then let ovs re-build the database is the key!

That wasn't the issue. If you look at your devices now they should be
sharing the same MAC address again. And if you restart the system, even
having the bridge recorded in ovsdb, it should keep working.

As I said in the previous e-mail to move the HWADDR line, the problem
is that your environment is forcing two devices to have the same name
and that is not possible. So, udev renamed eth0 to be br0 because of
HWADDR line and OVS silently fails to create the bridge device.

Easy to reproduce:
# ip link set dev p64p2 name br2   <-- set the NIC name to br2
# ovs-vsctl add-br br2      <-- create ovs bridge br2

# ovs-vsctl show
63afd35b-f94c-47dd-873a-bcb71fa0a885
    Bridge "br2"      <-- looks like we have it
        Port "br2"
            Interface "br2"
                type: internal

[root at i7 ~]# ethtool -i br2        
driver: bnx2      <-- but we don't
version: 2.2.5

There is a patch created during hackathon event by Andy, Ben and Thomas
to improve error reporting in OVS. 
http://git.openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=c3ccfe984933ca8df56d551cb3ae7e0bf3d119b8

Now ovs gives you:
# ovs-vsctl add-br br2
ovs-vsctl: Error detected while setting up 'br2'.  See ovs-vswitchd log
for details.
[...]

fbl



More information about the discuss mailing list