[ovs-discuss] Change OVS Advertised Port Speed

Ben Pfaff blp at nicira.com
Tue Nov 4 16:25:36 UTC 2014


The message from ethtool probably indicates that the kernel driver
doesn't support configuring that feature, so there probably isn't any
way to do it.  (This will still be the answer no matter how you rephrase
the question.)

On Tue, Nov 04, 2014 at 11:58:03AM +0000, Savvas Zannettou wrote:
> Hi,
> 
> Do you know what changes do i have to do in OVS source code so the default
> advertised link speed to be 10Mbps for example?
> 
> Thanks,
> Savvas
> 
> On Wed Oct 22 2014 at 4:48:16 PM Ben Pfaff <blp at nicira.com> wrote:
> 
> > The message from ethtool probably indicates that the kernel driver
> > doesn't support configuring that feature, so there probably isn't any
> > way to do it.
> >
> > On Wed, Oct 22, 2014 at 10:10:25AM +0200, Savvas Zannettou wrote:
> > > Hi,
> > >
> > > Do you have any other idea how i can change the advertised port speed of
> > > OVS?
> > >
> > > Thanks,
> > > Savvas
> > >
> > > On Tue, Oct 21, 2014 at 8:40 PM, Ben Pfaff <blp at nicira.com> wrote:
> > >
> > > > On Tue, Oct 21, 2014 at 03:24:03PM +0200, Savvas Zannettou wrote:
> > > > > I want to change the advertised speed for the OVS Switches that i
> > create
> > > > > from my mininet. The default value is 10Gbits/s and i want to
> > decrease
> > > > it.
> > > > > Do  you know any way how to achieve that from Mininet Api or any
> > other
> > > > way
> > > > > to get this done?
> > > > >
> > > > > I tried with ethtool but i get the following error:
> > > > > Cannot set new settings: Operation not supported
> > > > >   not setting speed
> > > >
> > > > That probably indicates that the kernel driver doesn't support
> > > > configuring that feature, so there probably isn't any way to do it.
> > > >
> >



More information about the discuss mailing list