[ovs-discuss] Logs in OVS

anuj kaul kaul.anuj at gmail.com
Mon Nov 10 16:50:06 UTC 2014

Hi ,

Thanks for your quick response.

I will try that also. I had tried* ovs-vsctl --version* in *mininet  *and
it showed the same version  as compiled by me.
Wanted to make sure mininet is using my compiled binary.


On Mon, Nov 10, 2014 at 8:46 AM, Ben Pfaff <blp at nicira.com> wrote:

> On Sun, Nov 09, 2014 at 10:28:39AM -0800, anuj kaul wrote:
> > I  have added few* VLOG_INFO* messages in* vswitchd/bridge.c* file .
> >
> > I checked ovs-dbserver is  running and also ran* ovs-vsctl show* command
> to
> > see if its working. It works fine .
> >
> > When i run mininet using  command *sudo mn .* It creates the topology*.
> *When
> > i look in logs under* /var/log/openvswitch/ovs-vswitchd.log* , I *dont*
> see
> > my log messages which I added but I  do see other log messages in the
> same
> > function in bridge.c
> Usually this means that you really aren't running the modified binary.
> Try adding something unmistakable to the source code, e.g. "abort()" as
> the first statement in main, and then see if it aborts immediately at
> startup.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://openvswitch.org/pipermail/ovs-discuss/attachments/20141110/624f1889/attachment-0002.html>

More information about the discuss mailing list