[ovs-discuss] creating a mgmt0 port and not able to ping it?

Ben Pfaff blp at nicira.com
Mon Nov 24 16:35:10 UTC 2014


On Sun, Nov 16, 2014 at 06:24:20PM -0800, frank weed wrote:
> I haved been trying to configure openvswitch to where I have a port for the
> host that will be the mgmt port and then have virtual machine client
> connected to it as well.  Here is my setup:
> 
> [root at localhost ~]# cat /etc/redhat-release
> CentOS Linux release 7.0.1406 (Core)
> 
> [root at localhost ~]# uname -a
> Linux localhost.localdomain 3.10.0-123.el7.x86_64 #1 SMP Mon Jun 30
> 12:09:22 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
> 
> Machine Type: Virtualbox
> 
> [root at localhost ~]# ovs-vsctl show
> xxxxxxx-xxxx-xxxxx-xxxx-xxxxx
>     Bridge "ovsbr0"
>         Port "enp0s3"
>             Interface "enp0s3"
>         Port "ovsbr0"
>             Interface "ovsbr0"
>                 type: internal
>         Port "mgmt0"
>             Interface "mgmt0"
>                 type: internal
>     ovs_version: "2.3.0"
> 
> If I try to configure mgmt0 with the host ip, and I can not ping to the
> host or out side of the host.  If I configure the ovsbr0 with the host ip,
> I can ping host and ping out side of the host. I even tried not configuring
> the interfaces with an ip and just setup openvswitch. I can see on tcpdump
> that the port mgmt0 is getting arp requests from other hosts. If I setup
> mgmt0 with the host ip I do not see tcpdump getting any arp request on the
> mgmt0 port.
> 
> My question is, I am wondering why mgmt0 is not accessible on the network
> when it is configured with a host ip. Also, is their something that I am
> missing that I need to make this setup work?

Is one of the interfaces on the bridge a physical NIC?



More information about the discuss mailing list