[ovs-discuss] help: about ovs bond configure

杜海涛 jeff.tu at qq.com
Thu Apr 9 04:41:55 UTC 2015


hi  everybody,
  I want to ask a question about ovs bond.please help me if you know it.
 i am a newbie for learning openvswitch,recently i got a problem when i config ovs bond.
 some detail as follow:
 my system version is centos7 ,kernel is 3.10.0-123.20.1.el7.x86_64. i already config physical switch LACP .
----
 [root at host26 network-scripts]# uname -r
3.10.0-123.20.1.el7.x86_64
[root at host26 network-scripts]# cat /etc/redhat-release 
CentOS Linux release 7.0.1406 (Core)‍
------
‍ I want to bind multiple network interfaces(such as  p2p1 and p3p1) together into a single,simultaneously‍
increasing the bandwidth and providing redundancy.‍
my config files is:
[root at host26 network-scripts]# less ifcfg-ovsbr0 
DEVICE=ovsbr0
ONBOOT=yes
BOOTPROTO=static
USERCTL=no
IPV6INIT=no
IPADDR=172.18.10.42        #another server  is  172.18.10.43
TYPE=OVSBridge
DEVICETYPE=ovs
HOTPLUG=no‍



[root at host26 network-scripts]# less ifcfg-bond0 
DEVICE=bond0
ONBOOT=yes
BOOTPROTO=none
USERCTL=no
IPV6INIT=no
OVS_BRIDGE=ovsbr0
TYPE=OVSBond
BOND_IFACES="p2p1 p3p1"
OVS_OPTIONS="bond_mode=balance-tcp lacp=active other_config:lacp-time=fast"
HOTPLUG=no‍



[root at host26 network-scripts]# less ifcfg-p2p1
DEVICE=p2p1
TYPE=Ethernet
ONBOOT=yes
HOTPLUG=no‍



[root at host26 network-scripts]# less ifcfg-p3p1
DEVICE=p3p1
TYPE=Ethernet
ONBOOT=yes
HOTPLUG=no‍



when i restart network


[root at host26 network-scripts]# ovs-vsctl show
60792242-29d8-4686-9cf5-1ea6cf99bc21
    Bridge "ovsbr0"
        Port "ovsbr0"
            Interface "ovsbr0"
                type: internal
        Port "bond0"
            Interface "p3p1"
            Interface "p2p1"
    ovs_version: "2.0.0"‍



[root at host26 network-scripts]# ovs-appctl bond/show
---- bond0 ----
bond_mode: balance-tcp
bond-hash-basis: 0
updelay: 0 ms
downdelay: 10 ms
next rebalance: 806 ms
lacp_status: negotiated


slave p2p1: enabled
        active slave
        may_enable: true
        hash 143: 0 kB load


slave p3p1: enabled
        may_enable: true
        hash 133: 0 kB load‍







root at host26 network-scripts]# ovs-appctl lacp/show
---- bond0 ----
        status: active negotiated
        sys_id: 00:0a:f7:75:ca:60
        sys_priority: 65534
        aggregation key: 1
        lacp_time: fast


slave: p2p1: current attached
        port_id: 2
        port_priority: 65535
        may_enable: true


        actor sys_id: 00:0a:f7:75:ca:60
        actor sys_priority: 65534
        actor port_id: 2
        actor port_priority: 65535
        actor key: 1
        actor state: activity timeout aggregation synchronized collecting distributing


        partner sys_id: 64:3e:8c:41:2d:50
        partner sys_priority: 0
        partner port_id: 3
        partner port_priority: 32768
        partner key: 9025
        partner state: activity aggregation synchronized collecting distributing


slave: p3p1: current attached
        port_id: 1
        port_priority: 65535
        may_enable: true


        actor sys_id: 00:0a:f7:75:ca:60
        actor sys_priority: 65534
        actor port_id: 1
        actor port_priority: 65535
        actor key: 1
        actor state: activity timeout aggregation synchronized collecting distributing


        partner sys_id: 64:3e:8c:41:2d:50
        partner sys_priority: 0
        partner port_id: 6
        partner port_priority: 32768
        partner key: 9025
        partner state: activity aggregation synchronized collecting distributing‍



my second server is 172.18.10.43, full same config as above just ip address!!


when i use iperf3 and ping to test the bandwidth,as follow:

i found the bandwidth is increasing,exceed one nic's throughput , but problem is coming.  when i down one of the physical nic,the network is interrupt about one minutes,in other words,it's can't providing redundancy normally,how can i change this config to ‍satisfy my ‍purpose.   ‍


I look forward to your early reply,thank you very much.‍


sincerely 

‍

2015.4.9
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://openvswitch.org/pipermail/ovs-discuss/attachments/20150409/2e366553/attachment-0002.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 98FA5B0C at AE440102.13032655
Type: application/octet-stream
Size: 22726 bytes
Desc: not available
URL: <http://openvswitch.org/pipermail/ovs-discuss/attachments/20150409/2e366553/attachment-0002.obj>


More information about the discuss mailing list