[ovs-discuss] [Q] LACP / VLANs Openvswitch Ubuntu 14.04

stuie_norris at exemail.com.au stuie_norris at exemail.com.au
Mon Apr 27 08:36:06 UTC 2015


Hi Forum,

I am trying to configure openvswitch to use LACP on a bonded interface on
Ubuntu 14.04 with VLANs using Cisco 3850X switches.

I want bond NICs eth2, eth3, eth4 and eth5 together.  On the server I will
have VMs on to VLANs 500 and VLANs 590.

On the Cisco 3850X Switch I have configures ether channel and enabled LACP.

interface Port-channel20
 switchport trunk native vlan 500
 switchport trunk allowed vlan 400-599
 switchport mode trunk

interface GigabitEthernet1/0/11
 description eth2
 switchport trunk native vlan 500
 switchport trunk allowed vlan 400-599
 switchport mode trunk
 channel-protocol lacp
 channel-group 20 mode active
!
interface GigabitEthernet1/0/12
 description eth3
 switchport trunk native vlan 500
 switchport trunk allowed vlan 400-599
 switchport mode trunk
 channel-protocol lacp
 channel-group 20 mode active

interface GigabitEthernet2/0/11
 description stage eth3
 switchport trunk native vlan 500
 switchport trunk allowed vlan 400-599
 switchport mode trunk
 channel-protocol lacp
 channel-group 20 mode active
!
interface GigabitEthernet2/0/12
 description eth4
 switchport trunk native vlan 500
 switchport trunk allowed vlan 400-599
 switchport mode trunk
 channel-protocol lacp
 channel-group 20 mode active

LACP can see the server from the switch.  (MAC shown matches MAC of vmbr0)

#show lacp neighbor
Flags:  S - Device is requesting Slow LACPDUs
        F - Device is requesting Fast LACPDUs
        A - Device is in Active mode       P - Device is in Passive mode

Channel group 20 neighbors

Partner's information:

                  LACP port                        Admin  Oper   Port    Port
Port      Flags   Priority  Dev ID          Age    key    Key    Number 
State
Gi1/0/11  FA      65535     001f.2958.ff36  14s    0x0    0x2    0x4     0x3F
Gi1/0/12  FA      65535     001f.2958.ff36  14s    0x0    0x2    0x5     0x3F
Gi2/0/11  FA      65535     001f.2958.ff36  14s    0x0    0x2    0x2     0x3F
Gi2/0/12  FA      65535     001f.2958.ff36  14s    0x0    0x2    0x1     0x3F


On the HP server I have the default Ubuntu 14.04 server OVS package
installed.
sudo dpkg -l | grep openvswitch
ii  openvswitch-common                  2.0.2-0ubuntu0.14.04.1          
amd64        Open vSwitch common components
ii  openvswitch-switch                  2.0.2-0ubuntu0.14.04.1          
amd64        Open vSwitch switch implementations

I have configured the /etc/network/interfaces to have

#cat /etc/network/interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# Bond eth2, eth3, eth4, eth5 together
allow-vmbr0 bond0
iface bond0 inet manual
  ovs_bridge vmbr0
  ovs_type OVSBond
  ovs_bonds eth2 eth3 eth4 eth5
  ovs_options bond_mode=balance-tcp lacp=active other_config:lacp-time=fast

auto vmbr0
iface vmbr0 inet manual
  ovs_type OVSBridge
  ovs_ports bond0 vlan500 vlan590

allow-vmbr0 vlan500
iface vlan500 inet static
  ovs_type OVSIntPort
  ovs_bridge vmbr0
  ovs_options tag=500
  ovs_extra set interface ${IFACE} external-ids:iface-id=$(hostname
-s)-${IFACE}-vif
  address 10.3.64.16
  netmask 255.255.255.0

allow-vmbr0 vlan590
iface vlan590 inet static
  ovs_type OVSIntPort
  ovs_bridge vmbr0
  ovs_options tag=590
  ovs_extra set interface ${IFACE} external-ids:iface-id=$(hostname
-s)-${IFACE}-vif
  address 10.3.71.16
  netmask 255.255.255.0

# The primary network interface
auto eth0
iface eth0 inet static
        address 10.3.74.16
        netmask 255.255.255.0
        gateway 10.3.74.1

auto eth1
iface eth1 inet manual

auto eth2
iface eth2 inet manual

auto eth3
iface eth3 inet manual

auto eth4
iface eth4 inet manual

auto eth5
iface eth5 inet manual

After reboot with above configuration

#sudo ovs-vsctl show
5211bfdb-f066-4a95-ae6e-de71acdc9072
    Bridge "vmbr0"
        Port "vlan500"
            tag: 500
            Interface "vlan500"
                type: internal
        Port "vlan590"
            tag: 590
            Interface "vlan590"
                type: internal
        Port "vmbr0"
            Interface "vmbr0"
                type: internal
        Port "bond0"
            Interface "eth5"
            Interface "eth4"
            Interface "eth3"
            Interface "eth2"
    ovs_version: "2.0.2"

The NICs have the following hardware addresses (Note the virbr0 - should
that be there?)

#ifconfig | grep -i HWAddr
bond0     Link encap:Ethernet  HWaddr b6:c5:80:b5:8d:1d
eth0      Link encap:Ethernet  HWaddr 00:1f:29:e2:dc:24
eth1      Link encap:Ethernet  HWaddr 00:1f:29:e2:dc:26
eth2      Link encap:Ethernet  HWaddr 00:1f:29:58:ff:36
eth3      Link encap:Ethernet  HWaddr 00:1f:29:58:ff:37
eth4      Link encap:Ethernet  HWaddr 00:1f:29:5c:1d:b8
eth5      Link encap:Ethernet  HWaddr 00:1f:29:5c:1d:b9
lxcbr0    Link encap:Ethernet  HWaddr aa:28:10:f2:3b:3a
virbr0    Link encap:Ethernet  HWaddr de:94:d0:e0:8d:ba
vlan500   Link encap:Ethernet  HWaddr fe:9a:2b:dd:e3:6f
vlan590   Link encap:Ethernet  HWaddr aa:ed:ab:d4:2a:d2
vmbr0     Link encap:Ethernet  HWaddr 00:1f:29:58:ff:36 (MATCHES what
Switch Sees)


sudo ovs-appctl bond/show bond0
[sudo] password for builder:
---- bond0 ----
bond_mode: balance-tcp
bond-hash-basis: 0
updelay: 0 ms
downdelay: 0 ms
next rebalance: 4808 ms
lacp_status: negotiated

slave eth2: enabled
        active slave
        may_enable: true

slave eth3: enabled
        may_enable: true

slave eth4: enabled
        may_enable: true

slave eth5: enabled
        may_enable: true

I have disabled the firewall on the server.

But I am unable to ping the VLAN 500 or VLAN 590 IPs

Could someone point me towards what I have setup wrong?

Thanks

Stuart




More information about the discuss mailing list