[ovs-discuss] Packet order mismatch between the interfaces

Murali Kandula muralispruce at gmail.com
Wed Aug 12 14:39:43 UTC 2015


Hello,

Is anybody have any idea why is this happening?.

Thanks

On Mon, Aug 10, 2015 at 8:39 PM, Murali Kandula <muralispruce at gmail.com>
wrote:

> The command "ovs-dpctl dump-flows" isn't showing anything. Attached are
> the tcpdump pcap files.
>
> ovs-ofctl dump-flows br0
> NXST_FLOW reply (xid=0x4):
>  cookie=0x0, duration=51922.609s, table=0, n_packets=0, n_bytes=0,
> idle_age=65534, dl_dst=00:0c:29:21:62:f7 actions=drop
>  cookie=0x0, duration=51922.540s, table=0, n_packets=0, n_bytes=0,
> idle_age=65534, dl_dst=00:0c:29:21:62:15 actions=drop
>  cookie=0x0, duration=51922.565s, table=0, n_packets=0, n_bytes=0,
> idle_age=65534, dl_dst=00:0c:29:21:62:0b actions=drop
>  cookie=0x0, duration=51922.581s, table=0, n_packets=0, n_bytes=0,
> idle_age=65534, dl_dst=00:0c:29:21:62:01 actions=drop
>  cookie=0x0, duration=51917.693s, table=0, n_packets=0, n_bytes=0,
> idle_age=65534, priority=0 actions=drop
>  cookie=0x0, duration=51922.553s, table=0, n_packets=0, n_bytes=0,
> idle_age=65534, dl_src=00:0c:29:21:62:15 actions=drop
>  cookie=0x0, duration=51922.569s, table=0, n_packets=0, n_bytes=0,
> idle_age=65534, dl_src=00:0c:29:21:62:0b actions=drop
>  cookie=0x0, duration=51922.586s, table=0, n_packets=0, n_bytes=0,
> idle_age=65534, dl_src=00:0c:29:21:62:01 actions=drop
>  cookie=0x0, duration=51922.620s, table=0, n_packets=0, n_bytes=0,
> idle_age=65534, dl_src=00:0c:29:21:62:f7 actions=drop
>  cookie=0x0, duration=24652.537s, table=0, n_packets=1307, n_bytes=165936,
> idle_age=207, priority=10,in_port=1 actions=FLOOD
>
>
> On Mon, Aug 10, 2015 at 8:18 PM, Abhishek Verma <abhishekv.verma at gmail.com
> > wrote:
>
>> This should ordinarily not happen. Can you mail tcpdump outputs where
>> youre seeing this?
>>
>> Can you also send the output of ovs-dpctl dump-flows along with that.
>>
>> On Tue, Aug 11, 2015 at 5:39 AM, Murali Kandula <muralispruce at gmail.com>
>> wrote:
>>
>>> Hello All,
>>>
>>> I am a newbie in openvswitch. I captured the packets at the both the
>>> interfaces eth2 and veth1 and observed that packet order is not same. For
>>> example let's consider the tcp packets (SYN, SYN_ACK, ACK). At the eth2
>>> interface the packet are correct but at the veth1 interface the packet
>>> order is changed to SYN, ACK and SYN_ACK.
>>>
>>> ovs-ofctl dump-ports-desc br0
>>>
>>>  1(eth2): addr
>>>      config:     0
>>>      state:      0
>>>      current:    1GB-FD COPPER AUTO_NEG
>>>      advertised: 10MB-HD 10MB-FD 100MB-HD 100MB-FD 1GB-FD COPPER AUTO_NEG
>>>      supported:  10MB-HD 10MB-FD 100MB-HD 100MB-FD 1GB-FD COPPER AUTO_NEG
>>>      speed: 1000 Mbps now, 1000 Mbps max
>>>  2(veth0): addr:
>>>      config:     0
>>>      state:      0
>>>      current:    10GB-FD COPPER
>>>      speed: 10000 Mbps now, 0 Mbps max
>>>  LOCAL(br0): addr:
>>>      config:     PORT_DOWN
>>>      state:      LINK_DOWN
>>>      speed: 0 Mbps now, 0 Mbps max
>>>
>>> cookie=0x0, duration=25551.309s, table=0, n_packets=25485,
>>> n_bytes=5694083, idle_age=319, priority=10,in_port=1 actions=FLOOD
>>>
>>> Please let me know what is the issue.
>>>
>>> Thanks
>>>
>>> _______________________________________________
>>> discuss mailing list
>>> discuss at openvswitch.org
>>> http://openvswitch.org/mailman/listinfo/discuss
>>>
>>>
>>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://openvswitch.org/pipermail/ovs-discuss/attachments/20150812/808bdeb3/attachment-0002.html>


More information about the discuss mailing list