[ovs-discuss] OVS with DPDK 2.1.0

gowrishankar gowrishankar.m at linux.vnet.ibm.com
Mon Aug 24 13:13:48 UTC 2015


On Monday 24 August 2015 01:05 PM, gowrishankar wrote:
> Hi,
>
> I could get build done and dpdk 2.1.0 running along with ovs 2.4.0.
> In case you wish to refer the changes I applied (including -ldpdk):
>
>           1. configure script to check libdpdk.a (not libintel_dpdk.a).
>           2. include libnuma-dev package if you enable 
> CONFIG_RTE_LIBRTE_VHOST_NUMA.
>           3. virtio-net.c:(.text+0x904): undefined reference to 
> `get_mempolicy'
>              configure script to also include libnuma along with libdpdk.
>
> TCP over vxlan overlay works unless the segment size is equal to MSS. 
> While at MSS,
> I see receiving guest dropping packets due to tcp checksum invalid. As 
> I see same

On some deeper inspection with snooping on dpdk ports between the 
systems (MTU 1450),
I observed that, when a payload size not more than 920, tcp checksum 
seems to be correctly
set by sender (as receiver validated and accepted). I tried sending tcp 
payload more than
this 920 and upto mss, but all these times, invalid checksum is reported 
in packet captures.

I could not get any clue on why this 920 is magical fig here.. I tried 
building dpdk with
possible CONFIG_RTE_LIBRTE_xx debug variables and loading dpdk again, 
but no debug
traces being reported in both syslog and ovs vswitchd log. Any pointer 
to inspect further ?


> cksum value thrown at sender side (though wrong!), I suspect sender 
> side has put
> wrong cksum. I used MSS not more than 1450 to accommodate vxlan 
> encapsulation.

Typo. MTU I meant.

> I had also tried disabling all possible offload features (tso,tx csum, 
> gso) in both guest's
> vnic (using ethtool). In fact, just switching dpdk sdk to 2.0.0 for 
> same OVS code did not
> cause any such problem (just to verify).
>
> I then tried same code base (just built for above dpdk ports) for a 
> plain vxlan (phy nic
> as tunnel end points). Everything works in TCP. I just thought of 
> sharing this checksum
> issue here so that, if anyone have already fixed, could you please 
> share your finding.
>
> Regards,
> Gowrishankar
>
> On Saturday 22 August 2015 10:17 PM, Gray, Mark D wrote:
>>> Hello,
>>>
>>> could you please tell me if OVS is already compatibile with recently 
>>> released
>>> DPDK 2.1.0? Or what sould I do to make it work, when I am receiving 
>>> "cannot
>>> link with dpdk" error - DPDK 2.0.0 works for me.
>> There are few small changes required which fix a performance regression.
>> We are going to post a patch in a couple of days. The issue you are 
>> seeing is that
>> the DPDK library name has changed. You could hold off until we post 
>> the full patch
>> or you could try changing DPDK_LIB="-ldpdk" in acinclude.m4.
>>
>> _______________________________________________
>> discuss mailing list
>> discuss at openvswitch.org
>> http://openvswitch.org/mailman/listinfo/discuss


-- 
Regards,
Gowrishankar M




More information about the discuss mailing list