[ovs-discuss] Problem while creating bond in open vswitch

sandesh shrestha sanshrestha08 at gmail.com
Wed Mar 11 02:28:07 UTC 2015


Dear All,

My open vswitch configuration is pasted below. I want to create bond with
s1-eth2,s1-eth3 and s1-eth4 but whenever I issue the command:

ovs-vsctl add-bond s1 bond0 s1-eth2 s1-eth3 s1-eth4, I am getting an error.

The error says: "ovs-vsctl: cannot create an interface named s1-eth2
because a port named s1-eth2 already exists on bridge s1"

Could you please tell me what's wrong with what I am doing ? I am trying to
create a bond so the interfaces should already be there. Why is it trying
to create the interfaces ?


root at mininet-vm:~# sudo ovs-vsctl show
aad071f2-ee72-47c0-a963-8cb5c033ad1b
    Bridge "s1"
        Controller "ptcp:6634"
        Controller "tcp:127.0.0.1:6633"
            is_connected: true
        fail_mode: secure
        Port "s1-eth1"
            Interface "s1-eth1"
        Port "s1-eth4"
            Interface "s1-eth4"
        Port "s1"
            Interface "s1"
                type: internal
        Port "s1-eth3"
            Interface "s1-eth3"
        Port "s1-eth2"
            Interface "s1-eth2"
    ovs_version: "2.0.2"


-- 
Sandesh Shrestha
Internetworking Student at U of Alberta
www.sandeshshrestha.net
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://openvswitch.org/pipermail/ovs-discuss/attachments/20150310/91ba8887/attachment-0002.html>


More information about the discuss mailing list